Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing the ATI proprietary driver, I disabled the Tear Free option because it causes laggy windows and general slowdown of everything.

But now I want to enable it again, to see whether it improves my video playing (which has lots of screen tearing). The problem is whenever I try to enable the option, it gives me "Tear Free Desktop cannot be enabled due to insufficient graphics memory".

I don't understand, as I could enable and disable it before no problems. I'm running on an ATI 4670.

Thank you in advance!

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Run this in a terminal, if you get any faults please add them to the question:

sudo aticonfig --set-pcs-u32=DDX,EnableTearFreeDesktop,1

share|improve this answer
    
It gives: "sudo aticonfig --set-pcs-u32=DDX,EnableTearFreeDesktop,1" but in amdccc it's still disabled. Is it done? –  James Oct 20 '11 at 14:18
    
if you got no faults yeah, it should be done. –  Bruno Pereira Oct 20 '11 at 14:27
    
maybe run amdccc as sudo will give you extra options? –  Bruno Pereira Oct 20 '11 at 14:27
    
did your tear go away? –  Bruno Pereira Oct 20 '11 at 14:28
    
I'm not really sure actually. Dragging windows does seem like there is no more tearing though! But playing videos still does...... hmmm :/ well thanks for your help! Good answer. I'll have to bookmark this page just in case. –  James Oct 20 '11 at 14:39
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.