Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Previously in Ubuntu, up until version 11.04, once I set the master volume to a level, it stays that way (regardless if I turn the machine off and back on) until I manually change it. Apparently, in version 11.10, there is a default master volume setting. No matter what I set my volume to, when I reboot the system, it always returns to that default setting (which for my tastes is a trifle too loud). Is there any way to change that default setting to the setting that I wish (about 50%)?

share|improve this question

3 Answers 3

Have you tried using alsamixer (man page) and alsactl (man page)? They are command line tool for alsa.

I usually just type: alsamixer, and when I'm done, alsactl store.
You may need to use sudo alsamixer and sudo alsactl store. May. Not neccessarily.

share|improve this answer
    
I've tried out your suggestion, and alas it didn't work, neither with nor without sudo. –  N.C. Weber Oct 23 '11 at 4:49

The following solved the problem for me (Ubuntu 12.04):

rm -r ~/.pulse ~/.pulse-cookie
share|improve this answer

I fixed this by choosing my desired volume level then typing the following:

sudo alsactl store
rm -r ~/.pulse ~/.pulse-cookie

The first line saves the desired volume (as explained at Wrong audio volume at boot), this didn't solve my issue by itself, on boot (the login scree) the volume was correct but after logging in the volume was at max again for my user. The second line then cleared any cached settings for my user so the desired volume was set on both boot and login. (found at How can I permanently set the master volume level?).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.