I'm trying to install emacs24 for an external repository, but I receive an error regarding unmet dependencies and wonder how I can continue the installation and resolve this error?
The output looks like this:
dito@dito:~$ sudo apt-get install emacs-snapshot-nox Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: emacs-snapshot-nox: Depends: emacs-snapshot-bin-common (= 1:20111012-1+squeeze1) but it is not going to be installed Depends: libncurses5 (>= 5.7+20100313) but 5.7+20090803-2ubuntu3 is to be installed PreDepends: dpkg (>= 1.15.6) but 18.104.22.168ubuntu4.5 is to be installed E: Broken packages dito@dito:~$