Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

/desktop/gnome/peripherals/keyboard/general/disable_indicator in gconf is set to yes

Additionally I restarted, but it's still there.

Maybe there is some setting buried in CCSM?


here is screenshot of what I'm talking about if it's not clear:

enter image description here

I want to remove it if possible

share|improve this question
1  
What layouts show up if you click on the button? I don't remember but I think that button appeared for me after I added "USA Dvorak" to my list of Layouts [in gnome-keyboard-properties -> Layouts] –  Matt Oct 23 '11 at 1:17
    
It does not show layout but drop-down menu for choosing layout: standard ASCII (USA) and my locale layout. Additionally there is menu shortcut for "keyboard preferences" and "show current layout". –  zetah Oct 23 '11 at 9:09
    
Oh, so you have more than 1 keyboard layout or not? If you have 2, try removing one [temporarily]. Then reboot, or log out and in again maybe? –  Matt Oct 23 '11 at 15:37
    
Hm... I don't want to remove my locale layout. I just want to remove this icon, while still being able to switch layouts. I guess this (gconf option) was working for 10.10 at least, but it's not working now. –  zetah Oct 23 '11 at 15:58
    
Alright then, guess I can't help ya.. –  Matt Oct 23 '11 at 21:01
add comment

5 Answers 5

up vote 4 down vote accepted

enter image description here

To completely remove the keyboard indicator we need to change one byte in the file

11.04 and before

/usr/lib/gnome-settings-daemon-2.0/libkeyboard.so

11.10 and after

/usr/lib/gnome-settings-daemon-2.0/libkeyboard.so

(make backup libkeyboard.so)

open file with root privileges through any hex editor (i use Bless)

and search for the byte signature FF 83 F8 01 0F

FF 83 F8 01 0F = if (g_slist_length (current_kbd_config.layouts_variants) > 1)

and change 01 to 02

FF 83 F8 02 0F

save file

FF 83 F8 02 0F = if (g_slist_length (current_kbd_config.layouts_variants) > 2)

if you have less than 3 keyboard layouts icon will be not shown

after this work need to reload gnome-settings-daemon

you can use reboot for this.

share|improve this answer
    
It does what it says. Thank you –  zetah Jan 12 '12 at 6:06
    
Mine was at: /usr/lib/gnome-settings-daemon-3.0/ –  Gringo Suave Apr 1 at 2:03
add comment

In version 13.10 and newer of Ubuntu you can just tick it off in Text 'entry settings' (last menu options when you click the keyboard icon). Tick off the 'show current keyboard' option.

share|improve this answer
add comment

If you wished to remove the Keyboard icon and keep the Language selector then it is as follows:

@ Terminal

  1. find /usr/share/icons/ -name "input-keyboard.??g" -exec sudo mv {} {}.old \;

  2. for i in $(find /usr/share/icons/ -name '.old'); do sudo mv $i ${i%.}; done

If you wished to remove both the Keyboard icon and the Language selector then it is as follows:

  1. Open your Configuration Editor

  2. Click Apps --> gnome_settings_daemon --> plugins --> Keyboard --> Unchecked 'Active'

  3. Log out and log in. The Keyboard icon and the Language selector will not appear.

NB: If you couldn't locate your Keyboard at the Configuration Editor, then do this: http://gnome-look.org/content/show.php/?content=140209

share|improve this answer
    
I give you my bounty little too early. Apps/gnome_settings_daemon/plugins/Keyboard = 0 disables locale layout support, so that's not what I'm after. –  zetah Oct 25 '11 at 17:31
    
"Flag" solution OTOH is best from provided answers, so I'll mark it as answered if there are no more answers in this couple of days. Cheers –  zetah Oct 25 '11 at 17:45
add comment

It looks like "Keyboard Indicators plugins" may have been installed. Run the Software Center to check and remove it.

share|improve this answer
    
Unfortunately "Keyboard Indicators plugins" is not installed. This indicator applet appeared right after I installed (and updated) 11.04, some days ago –  zetah Oct 23 '11 at 9:06
    
Check out the dconf-editor under org - gnome - libgnomekbd - indicator. There are some parameters there that may be helpful, namely enabled-plugins and perhaps show-flags. It the only other thing I could think of although I have to admit being in guess mode because I can't duplicate you situation. –  fragos Oct 23 '11 at 21:52
    
There is no such key in dconf-editor. Additionally I browsed for any trace of this indicator without success –  zetah Oct 23 '11 at 22:14
add comment

If you find that the keyboard indicator is useless, you can easily remove the applet from top panel by following the steps below:

  1. Open System Settings from Unity Launcher or from top-right corner shutdown menu. Then click on Text Entry

  2. In the bottom of the window you’ll see “Show current input source in the menu bar” which is enabled by default. Uncheck the box and the indicator applet will disappear instantly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.