Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded to 11.10 and I have a HP Mini 2140 with a swiss layout keyboard. I could set that on the system setting and for the keyboard I have no problems. But I also use a Logitech DiNovo Edge bluetooth keyboard when I'm at home, and there is no way to set it in the right layout (the french swiss one).

How can I correct that? It's very strange because when I connect my Logitech keyboard is set on the American layout, but the one of the PC is still on the swiss french layout.

share|improve this question

closed as too localized by fossfreedom Mar 10 '12 at 15:27

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I've got the same problem with my Logitech DiNovo with German layout. Therefore I'm starting a bounty. –  K. Hendrik Nov 23 '11 at 9:31
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  fossfreedom Mar 10 '12 at 15:27

1 Answer 1

Old bluetooth pairings might not be 100% compatible with newer/upgraded Ubuntu 11.10.

Simply remove the keyboard from the list of paired devices, then "re-pair/reconnect" it. Use the "connect" button underneath the keyboard.

Once it's been paired again, the correct layout should be active.

It's generally a good idea to unpair/re-pair all bluetooth devices after a system upgrade, as the bluetooth profiles and drivers has been updated. New features won't activate until a device has been paired anew.

share|improve this answer
    
Thanks for your answer, but re-pairing my keyboard doesn't solve the problem at all. Still blocked to the US-English layout. –  user29215 Oct 27 '11 at 9:08
    
I think that the problem come from the login page, when I log on using the laptop's keyboard, then I start using the bluetooth keyboard the layout is fine. If I login using directly my bluetooth keyboard, the one on the laptop doesn't work at all and the bluetooth one is stuck on the US-English layout. –  user29215 Oct 27 '11 at 9:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.