Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Despite Chromium being set as my preferred web browser under "System Info", when I click a link in an IM window of Pidgin, it opens in Firefox. How do I make it so that links open in Chromium?

I am running:

  • Ubuntu 11.10
  • chromium-browser 14.0.835.202~r103287-0ubuntu1
  • pidgin 1:2.10.0-0ubuntu2

EDIT:

I also tried sudo update-alternatives --config x-www-browser and selected chromium (in both auto and manual mode), but after running sensible-browser & it still loads Firefox.

Chromium is also set to the default browser within the Chromium -> Preferences -> Default Browser panel.

share|improve this question

3 Answers 3

If you are on a gnome system, gnome-www-browser is checked before x-www-browser, so you might have more luck changing this alternative with

sudo update-alternatives --config gnome-www-browser
share|improve this answer
1  
This is the real answer. –  Kumar Harsh Mar 11 at 5:44

a first suggestion would be to manually check your preferences by editing the file

~/.purple/prefs.xml

there you can find the following lines (in the tag pidgin => browsers:

<pref name='browser' type='string' value='custom'/>
<pref name='place' type='int' value='0'/>
<pref name='manual_command' type='string' value='sensible-browser'/>

I suggest you to have those three lines like they are given in my example.

If this is correct, you should try to run:

sensible-browser &

from a shell to see whether your preferred browser is setup correctly.

I hope this helps you to get further with your issue.

Greetings from switzerland, Michael K

share|improve this answer
1  
My prefs.xml browser settings file is identical to yours, but when I run sensible-browser &, Firefox opens, not Chromium. –  paniwani Oct 20 '11 at 10:53
up vote 1 down vote accepted

When I installed and set my default browser to Chrome stable, sensible-browser & opened up Chrome correctly.

It must have just been an issue with Chromium.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.