Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu Natty (11.04) a while ago and also CompizConfig Settings Manager (ccsm) for better display effects.

This was working fine till now but since a few days ago due to some unknown reason

1) The minimize,maximize,close buttons get disappeared at start-up. 2) even the show desktop button when clicked shows "your window manager does not support the show desktop button, or you are not running a window manager" and the window switcher also doesnt work.

They were only restored when I ran the command "compiz --replace" or "metacity --replace" in the terminal everytime after the system booted up which not only restored all my windows back to normal as they were after I had installed Natty but also led to the terminal hanging up as if it was closed then it called for a reboot as I virtually couldnt access anything simultaneously.

Now I uninstalled CompizConfig Settings Manager (ccsm) as well as Unity and kept only the Metacity but I still face the problem which gets resolved only after I run "screen metacity --replace" on every reboot

Please help me with a solution that will restore my windows back to normal permanently and which doesnt involve typing or running anything everytime in the terminal after boot.

Thanks a million

share|improve this question

1 Answer 1

up vote 0 down vote accepted

first a hint: if you want to run a process on a terminal in background (you described it as "terminal hanging") you should append an "&" to it:

metacity --replace &

I guess at bootup neither metacity nor compiz are running on your machine. It is difficult to say why this happened.

A suggestion would be to reinstall the desired manager (compiz or metacity).

greetings from switzerland, Michael

share|improve this answer
    
Thanks for the suggestion,sir but it doesnt seem to solve the issue completely. Although,what you said is a good way to keep the terminal from hanging up but that can also be done by "screen metacity --replace". And your guess is absolutely right that neither compiz nor metacity are running at bootup..What I want is,how that can be done so as it will save me the trouble of running the terminal at bootup.. –  Vinay Hegde Oct 20 '11 at 17:09
    
you can run your prefered manager as an autostart application (see Menu System -> Preferences -> Start Applications). The names might differ slightly as I do not have the english version setup. –  Michael K Oct 24 '11 at 5:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.