Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug my iPhone (iOS 5) into my laptop with Ubuntu 11.10, I get this error:

Unable to mount Documents on iPhone. Location is already mounted

followed by this error:

Unable to mount iPhone. Location is already mounted

After I see these errors, the "Documents on iPhone" folder pops up. How do I fix this?

share|improve this question

2 Answers 2

up vote 5 down vote accepted
sudo apt-get install libimobiledevice-utils;idevicepair unpair && idevicepair pair
share|improve this answer
5  
While this may technically answer the question, could you also include what these commands do in a terminal? –  Lekensteyn Oct 28 '11 at 9:08
1  
Worked. Thanks! –  paniwani Oct 31 '11 at 1:42
    
also worked on 12.04. thanks. –  goker.cebeci Jun 5 '12 at 3:01

@Lekensteyn - here is a simple description of these commands do:

  1. download and install library 'libimobiledevice-utils' from known sources

    sudo apt-get install libimobiledevice-utils
    
  2. and once done

    ;
    
  3. unmount and mount your iPhone

    idevicepair unpair && idevicepair pair
    

Running a command with sudo will require you to have root access rights and you'll be prompted to input password for root user. So technically it may not be possible in a corporate/locked-down environment where users are not deemed to have root access.

share|improve this answer
1  
This worked but only when I did slide to unlock -> enter 4 digit pin before #3, as stated on this ubuntuforum –  David Feb 29 '12 at 18:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.