Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a Dell Vostro 1014 laptop with Ubuntu 11.10. From the time I had Ubuntu 9.04, sound comes from the laptop speakers only even when I plug in earphones or external speakers. Also, if an external microphone plugged in, it does not work. Dell even replaced my motherboard to check for hardware issues but the problem persists. So it is definitely not a hardware issue. The sound plays perfectly through the headphones in the pre-boot diagnostics. So I figure, this must be a problem with Ubuntu not recognizing my sound card.

Please try to give a solution for this problem.

share|improve this question
add comment

6 Answers

up vote 2 down vote accepted

I had the same problem: I plug in headphones, and sound comes out of the headphones and my laptop speakers.

Here's how I fixed this problem:

Go to Sound Preferences [click on the Sound icon in the top-right, on the bottom of the menu, you'll see sound preferences]

Next, go to the Output tab.

Here, look at the bottom, where it says "Connector:"

I think mine was on "Analog Speakers" [or possibly "Analog Headphones"].

Change it to "Analog Output"

Please try to tell me if this solution fixes your problem.

Also, you can try alsamixer to manaully turn down the Speaker volume.

share|improve this answer
    
Thank you. It works! –  Ankush N Nayak Oct 20 '11 at 5:44
    
Sweet, no problem! :) –  Matt Oct 20 '11 at 15:37
    
I do not have the option Analog Output :( is there some way to fix this for me also? I can not get sound from my laptop speakers at all, but only from my headset. –  Sam S Nov 5 '11 at 6:42
add comment

I had the same problem. Here's how I fxed it:

  1. Right click on sound icon on right bottom of your taskbar.
  2. Click on 'Playback devices'.
  3. Left click on 'Communication headphones'.
  4. Then click on 'Properties" option down in the same window.
  5. Then click (in next window which opens) on 'Enhancements'.
  6. Unmark "Disable all enhancements" and tick mark the rest three options that is "Bass boost", 'Headphone Virtualization' and "Loudness equilization".
  7. Click apply and OK.
share|improve this answer
add comment

Toshiba Satellite-L645D headphones Ubuntu 11.04

Open the terminal and run this commands:

cd /etc/modprobe.d/
sudo chmod 666 alsa-base.conf

Open the alsa-base.conf file with your preferred text editor, and copy this in the last line:

"options snd-hda-intel model=thinkpad"

Restart your computer. Enjoy it.

share|improve this answer
add comment

This Might be a similar issue I just fixed in my laptop give it a try, here are the details of the fix:

Sound not coming out of speakers, only headphones, on laptop FIXED.

The speakers on my laptop Dell Studio XPS 1640 were not working after experimenting with several modules and models, I decided to give it a try on Windows (should've tried it sooner, try it first if you are doing double boot), I was expecting them to work but they did not, which meant it was a problem in the hardware not the codecs, module or model.

The codec of my sound card is using on Ubuntu 11.10 is 'STAC92HD73', I added the following option to my alsa-base.conf file and rebooted.

#add this at the end of /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=no-jd

After reboot sound is coming out from both laptop speakers and headphone jacks (at the same time, but no biggie just go to sound settings and select 'analog headphones' for output when only listening to headphones, also make sure analog speakers is selected for output after reboot), it seems the headphone jack-detection broke and that is why sound was not comming out of the speakers. Adding the no-jd (no jack detection) fixed the issue.

Hope this helps, it was driving me nuts for the last two weeks.

share|improve this answer
add comment

I'm using a Dell Vostro 1014 laptop with Ubuntu 11.10. From the time I had Ubuntu 9.04, sound comes from the laptop speakers only even when I plug in earphones or external speakers. Also, if an external microphone is plugged in, my speakers don't work. Dell even replaced my motherboard to check for hardware issues but the problem persists. So it is definitely not a hardware issue.

The sound plays perfectly through the headphones in the pre-boot diagnostics. So I figure, this must be a problem with Ubuntu not recognizing my sound card and so a driver-related issue of some sort.

share|improve this answer
add comment

I was having issues with the headphones being partially ignored by the system. It was only playing a few system sounds through them and then ignoring that they were plugged in all together. Playing music through speakers etc. while they were in.

After fiddling around for an hour or so and reading different solutions I simply decided to set my speakers to the default communications device in control panel under the "sound" option (Win 7). Afterwards I tried playing some music and my headphones were back to normal.

All of the problems had been fixed. Not sure why exactly the audio went haywire. Probably a combination of Skype and Steam trying to control the sound at the same time. Give it a shot if you're having similar problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.