Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How does one prevent Nautilus from automatically opening a window when a USB flash drive is inserted in Oneiric?

The autoplay options appear to be missing from Nautilus' preferences, and using gconf-editor to enable 'media_autorun_never' (as suggested by this old thread: http://ubuntuforums.org/showthread.php?t=974087) appears to have no effect, even after logging out and logging back in.

share|improve this question

2 Answers 2

up vote 5 down vote accepted

In System Settings -> Removable Media you have the options for that...

share|improve this answer
1  
Thanks--that worked great. For people using alternative windows managers (Xmonad for the win), System Settings can be accessed with the command gnome-control-center –  cqcallaw Nov 24 '11 at 3:11

The option in System Settings only allows you to block auto-plays from all insert-able media. If you want to block unknown devices such as memory sticks, but keep customized settings such as automatically loading your favorite DVD player when inserting a DVD, then you need edit the settings through the dconf-editor (the gconf-editor method didn't work for me either).

See this launchpad discussion for details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.