Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First the picture:

enter image description here

As you can see in the image, the colors used for the icons and the words Applications and Places (In spanish in this case) have a different background dark gray color than the rest of the panel. Also the icons look rather bigger in that panel. Now my questions are:

  1. Can the background colors be customized so they look the same all the way through the panel.

  2. Can the icons be somehow minimized a little so they don't look strange (bigger actually)

  3. How to edit the way to add icons to the panel. I have to actually hold the ALT key and right click on it to show the context menu which shows me the option to add something. That extra key press is not friendly at all.

In this particular case I am trying to help an older man start in Ubuntu. Unity is too much for him but Gnome is friendlier for him (Learning curve is not the best for older people.. specially 68+ year old people).

share|improve this question

6 Answers 6

up vote 61 down vote accepted
+200

How to get back a "GNOME 2 look and feel" in Ubuntu 11.10 Oneiric Ocelot

1. Install "GNOME Classic" session

sudo apt-get install gnome-session-fallback

You now get the possibility to choose the "GNOME Classic" session when you log in, but there are some problems with this session:

  • The top panel's height and its icons are too large
  • The panel background is inconsistent

GNOME Classic:
orig

With the fixes below:
fixed

After turning sound and bluetooth off and on again:
fixed-compacticons

The fixes also work for the Radiance theme:
fixed-compacticons-radiancetheme

2. Reduce the size of the icons to 16 pixels

This will also reduce the height of the top panel from 30 to 24 pixels.

2a. Create folder for config files:

mkdir ~/.config/gtk-3.0

2b. Create or edit ~/.config/gtk-3.0/settings.ini and add this:

[Settings]
gtk-icon-sizes = panel-menu=16,16:gtk-large-toolbar=16,16

3. Fix the panel background

Note: Instead of the following solution, the background can also be fixed by using:
(Win-)Alt-rightclick on panel -> Properties -> Background -> Solid color

3a. Create or edit ~/.config/gtk-3.0/gtk.css and add this:

/* Fallback Mode Panel */
/* Fix background color (needed in Ubuntu 11.10 Oneiric Ocelot). */
/* Based on /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css. */

PanelWidget,
PanelApplet,
PanelToplevel {
    background-color: @dark_bg_color;
    background-image: none;
}

.gnome-panel-menu-bar,
PanelApplet > GtkMenuBar.menubar,
PanelApplet > GtkMenuBar.menubar.menuitem,
PanelMenuBar.menubar,
PanelMenuBar.menubar.menuitem {
    background-color: @dark_bg_color;
    background-image: none;
}

PanelAppletFrame {
    background-color: @dark_bg_color;
    background-image: none;
}

At this point, you should log out and in again using the "GNOME Classic" session in order to see the changes.

4. Further panel configuration

Use (Win-)Alt-middleclick-drag and (Win-)Alt-rightclick to configure the panel further.

Note that the panel items snap to the left/center/right of the panel, so they might need to be dragged some distance before they move at all.

Launchers can easily be added by dragging items directly from the Applications menu to the panel.

5. Fix icon spacing

There seems to be a bug which causes excessive spacing between the icons in the notification area tray:

fixed

An easy fix is to change the icons back and forth, e.g. muting/unmuting the sound and disabling/enabling bluetooth. This solution is unfortunately only temporary and must be performed again after each login.

fixed-compacticons

Final remarks

Make a note for future reference that you just added two config files in:

~/.config/gtk-3.0/

This is nice to know in case the config files mess things up with later Ubuntu releases and need to be removed again.

Results

Before:

After:

See also

share|improve this answer
1  
+1 ... even better with the old indicator applet instead of the ugly gnome equivalent! askubuntu.com/questions/69377/… –  fossfreedom Nov 7 '11 at 20:45
    
Wow, fantastic first answer. –  Kris Harper Nov 10 '11 at 19:59
    
Ok, this may not be related to panel, but i think i should ask here..../.in gnome 2 i can acheive small-toolbar effect (/desktop/gnome/interface/toolbar_icon_size) from gconf-editor. How can i do the same in gnome3? I tried to add it in ~/.config/gtk-3.0 like this gtk-icon-sizes=gtk-small-toolbar=16,16, but that didn't help. Is it hardcoded into theme? Any idea? –  Khurshid Alam Jul 14 '12 at 9:47
1  
+1 just for the bit about needing Win+Alt+Right Click to customize the panel. –  Russell Silva Jul 19 '12 at 15:57
    
I would also like to know which component handles the configuration in ~/.conf/gtk-3.0/* and what other settings can I change there. –  Robert Siemer Mar 19 at 7:50

You must use Alt + Right Click in the panel... In some cases its Super+Alt+Right CLick. You will see the properties option, as well as Add To Panel :-)

share|improve this answer
    
i was trying all and any combinations, except, of course, super+alt+rclick... thanks. –  njzk2 Jun 12 '13 at 8:26

if you follow these instructions, you will have an excellent panel, just like we used to in 10.10 and 11.04. it will get you the exact kind of panel that you want :)

To install Indicator Applet for GNOME 3 (classic/fallback session) in Ubuntu 11.10, use the commands below:

sudo add-apt-repository ppa:jconti/gnome3
sudo apt-get update
sudo apt-get install indicator-applet indicator-applet-complete indicator-applet-session

To also install the Global Menu indicator applet for GNOME 3 classic session, use the command below:

sudo apt-get install indicator-applet-appmenu

Once installed, you can remove the existing applets that you don't need such as the clock or user menu from the GNOME 3 classic session top panel - to do this, ALT + right click them and select "Remove".

Then, to add the GNOME 3 Indicator Applet to the panel, right click the top panel while holding the ALT key and select "Add to panel" and from the applets list, add "Indicator Applet Complete". To get a Global Menu, also add "Indicator Applet Appmenu".

Please note that if you don't remove the notification area (systray) from the top panel, you'll get an extra sound icon. Unfortunately I couldn't find a fix for this. Also, if you want to move/remove the systray, don't ALT+RIGHT CLICK on it but in front of it (there's a very small invisible area).

And a final tip: to fix the panel, ALT + RIGHT CLICK it and for the background, use "#303030" color (for Ambiance theme). Alternatively, install a GTK theme that supports the new GNOME 3 panel

Enjoy :)

share|improve this answer

In short the solution to problem 1 is to correctly set the background image according to the ambiance theme.

ALT+right click on panel and select 'Properties'. Select tab 'Background' and set 'Background image' to /usr/share/themes/Ambiance/gtk-2.0/apps/img/panel.png

I found a detailed step-by-step how to with pictures and this solution over here

share|improve this answer

This works, the only problem left is fixing the font color on the Window List.

EDIT: I found a fix that works for me. Just include this snippet as well in the gtk.css file:

PanelApplet .button,
PanelApplet .button:prelight {
    color: #aaaaaa;
}

EDIT2: It appears the fonts were fixed in the theme distributed by Ubuntu now, so this is no longer needed.

share|improve this answer
    
I had to create ~/.config/gtk-3.0/gtk.css (and then `killall gnome-panel', of course), but this worked for me. Thanks! –  David Krider Mar 4 '12 at 16:02

You can also customize the Applications and Places menu names using the language file. I changed "Applications" to "Apps". This saves some valuable space.

1) Download the oneiric gnome-panel .po file for your language from bazaar.launchpad.net

2) Edit the string you wish to change in the .po file. It's easiest to use a UTF-8 text editor, like gedit. Original:

    #: ../gnome-panel/panel-menu-bar.c:183
    msgid "Applications"
    msgstr "Applications"

Edited:

    #: ../gnome-panel/panel-menu-bar.c:183
    msgid "Applications"
    msgstr "Apps"

3) Run msgfmt on your edited file, creating messages.mo. Rename it gnome-panel-3.0.mo, change the owner and group to root.

4) Make a backup of the file we are going to replace, at /usr/share/locale/?/LC_MESSAGES/gnome-panel-3.0.mo (with ? being the locale you're using). Just in case something goes wrong.

5) Replace the file at /usr/share/locale/?/LC_MESSAGES/gnome-panel-3.0.mo (with ? being the locale you're using) with your edited file.

6) Logout and login. Or run killall gnome-panel.

share|improve this answer

protected by Community May 2 '12 at 20:35

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.