Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Fresh install of 11.10: Right after installing restricted drivers (nvidia) all audio devices disappear. Why could it be?

EDIT: Also, after disabling these restricted drivers, the audio devices (sound card, webcam) reappear.

share|improve this question
Disappear from where? – Oli Oct 20 '11 at 2:11
Sound settings: Hardware, Input, Output, everywhere. – Jacob Oct 20 '11 at 2:12
Oli, it turns out you were right. After some enabling, disabling, enabling again and disabling again, the audio devices reappeared and then I quickly did what you suggested. Right now the sound is working and the nvidia video drivers are working as well. I hope it keeps working! Thank you for your help. – Jacob Oct 20 '11 at 2:57

Modern Nvidia cards that have HDMI outputs have the option of acting as a sound card (so you can get audio over HDMI). What I suspect has happened is something has detected this new sound card and has changed your audio settings to HDMI.

Open up the Sound Preferences screen and you should be able to configure it something like this:

enter image description here

Select the GFxxx device and change its profile to Disabled. Then select the other device (Internal Audio in my case) and set that to the sound profile you want. That should be all you need to do.

share|improve this answer
Trying that....BRB – Jacob Oct 20 '11 at 2:17
Based on your other comment, I don't think this will make any difference - but it might. If it doesn't, let me know and I'll delete this answer. – Oli Oct 20 '11 at 2:22
Didn't even have the chance. This time, disabling the restricted drivers didn't bring back the audio devices. With no audio devices, there's no disabling the GFxxx and such. – Jacob Oct 20 '11 at 2:24

A way I found to temporarly fix it was to kill the "pulseaudio" process and wait for it to begin and to load anew. Just in case somebody else has the issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.