Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to upgrade to Ubuntu 11.10 through the upgrade wizard. I had about 30 minutes left on my install, and had to leave. When I came back, my computer was frozen, so I had to do a hard reset.

When it rebooted, I was shown this screen: jail :(

It appeared unresponsive, but I could ctrlaltF1 and get to the terminal where I could log in. It appears that I am not connected to the 'net - sudo dhclient only appears to output one line of text rather than the several that it should. ping does nothing, but I can ping localhost -c 4.

I was hoping that following the instructions here would give me a plain screen without any X startup (that was my theory on why it didn't look good) but it didn't appear to have any effect - also where the author had 7 lines of output, I had only one (which I can't read, of course).

any ideas about what I can do? I suspect it may be an issue with the video card drivers - I have some NVidia card (computer posts just fine, so I know the issue is after the OS takes over). I don't remember if I installed GRUB, but I didn't see any menu pop up the several times I booted. On two boot-ups it actually showed the Ubuntu splash screen, but there it hung and I couldn't get to the terminal like it does when I get the "jail" screen.

If I could get it hooked up to the network I have sshd installed (at least I can ssh to localhost, and I could SSH in from other computers before my upgrade), and could log in and see what I could fix that way.

Worst case scenario, I believe I partitioned off my /home/ directory, so I could reinstall just the OS portion, but I don't really want to do that - I had a lot of problems initially installing Ubuntu with this hardware configuration in the first place and I don't want to go through that again.

So any help would be greatly appreciated!


share|improve this question

Since you can get to the console, probably easiest thing to try first is to log in and run:

sudo apt-get install --fix-broken

If the problem is merely that some packages hadn't finished configuring, it should be able to complete that, network or no.

share|improve this answer
doesn't appear to work - it gives me an output of two lines... – Wayne Werner Oct 20 '11 at 2:21
up vote 2 down vote accepted


sudo dpkg --configure -a

worked! There were several cases where it asked for user input, and I just hit enter for most things. There were a few screens where it popped up a curses-style GUI, and I mostly had to guess where the "OK" buttons were. After the lengthy process, I did sudo shutdown -r now and when it finished rebooting, I was presented with the new Ubuntu login screen. Success!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.