Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently replaced Unity on my 11.10 install with XFCE/Xubuntu. So far I have only one problem, which is pretty much identified and solved here:

How to stop nautilus managing desktop in unity

The trouble is, that advice requires a 65meg download. I can't believe it's doing any more than changing a single config entry somewhere. Unfortunately I'm still too noob at Ubuntu to find this myself. All the advice I can see is for earlier versions of XFCE so the setting I'm supposed to change using gconf-editor or settings manager doesn't exist (or must have an entirely different name which has so far thwarted my feeble attempts to locate it).

Does anyone know where this setting is and how it can be changed outside of gnome-tweak-tools. I'd quite like to uninstall it now but am afraid it'll go back to how it was before.

share|improve this question
    
Are you sure that's not 65KB? Seems strange that it would have so many dependencies. –  Jo-Erlend Schinstad Oct 19 '11 at 22:43
    
Yeah, it pulled down quite a lot. Is it possible for me to check what it got? –  Poldie Oct 19 '11 at 23:27
    
Might it just be that I've just done a clean install of 11.10, and installed little else so far? –  Poldie Oct 20 '11 at 0:03
    
gnome-tweak-tool actually depends on gnome-shell, so it has downloaded it. –  Jo-Erlend Schinstad Oct 20 '11 at 0:51
1  
Ok, so that's why it's so large, but what's the connection between gnome and xubuntu/xfce? Do I actually need any Gnome components at all? Isn't there an XFCE config too which tells Nautilus to back off? Or is there a dependancy between Nautilus and Gnome? I want to learn more about this sort of stuff - is there a book or site which explains how these things are implemented, configured and related? –  Poldie Oct 20 '11 at 7:28
add comment

3 Answers

In at least 11.04 this works:

sudo apt-get install gconf-editor

in gconf-editor (a small program!)
umark: / apps / nautilus / preferences / show_desktop

it says:
"Nautilus handles drawing the desktop
If set to true, then Nautilus will draw the icons on the desktop."

found it at [SOLVED] Stop Nautilus from managing the desktop? - Ubuntu Forums

share|improve this answer
    
Thanks, but I have ditched Ubuntu on all but one PC because of Unity. Rather than install version of Linux and then change the UI away from the default, I've found it better to install Linux Mint and use Mate (a fork of Gnome 2). I'm all in favour of progress, change, improvements and all that, but Unity is just too inflexible and unintuitive - I just have no idea how to do stuff, and whenever I google it seems what I want is impossible. I didn't leave Windows for that. –  Poldie Jan 1 '12 at 0:56
add comment

If you don't want to add stuff that is not necessary to your computer, you should be glad to remove stuff that is the very source of your problem.

Had the same problem and got rid of Nautilus in favor of Thunar. Now the problem is solved.

Nautilus is too aggressive in Xfce, so I don't mix the two. The only app that partly needed Nautilus was Dropbox (it installed Nautilus without me noticing, I think).

share|improve this answer
add comment

One option you have is to remove Nautilus

Open Terminal (Ctrl+Alt+T) and type:

sudo apt-get purge nautilus
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.