Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Synaptic keeps crashing. When I open it, it asks for the sudo password. I give the password, then the synaptic window flashes for less than a second and then goes away.

What's wrong?

After seeing this problem I uninstalled synaptic using apt-get. Uninstalled, cleaned, removed, auto-removed, purged... every possible option from apt-get.

Then I tried installing synaptic from scratch. Still no luck.

Help please! I just did a clean install of Ubuntu 11.10 yesterday.

I also removed the ~/.synaptic folder -- no luck.

Here is the terminal output:

$ sudo synaptic
terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check
share|improve this question
I have the same problem and have yet no idea why it happens, might be a bug from a recent update. But i have a workaround for you: if you open it with "sudo synaptic", at least for me it works. – Dominik Oct 19 '11 at 21:40
hey @Dominik, i have added my sudo synaptic output of the terminal in the edit....... no luck. – syedrakib Oct 19 '11 at 22:47
solve it.... posted the answer the question update ... check it out – syedrakib Oct 19 '11 at 23:23
Do not post the answer IN the question put it as A proper Answer below!. – Uri Herrera Oct 20 '11 at 3:37
thanks @UriHerrera – syedrakib Oct 22 '11 at 2:24
up vote 14 down vote accepted

Solved it

from this link in In the post, Jsonwco writes:

It appears that it's related to accessibility settings. I was able to fix this problem on my system by opening Universal Access, enabling then disabling the screen reader, then opening Synaptic again.

share|improve this answer
Toggling the on-screen keyboard under accessibility settings worked for me. Thanks. – Usagi Nov 3 '11 at 15:56
thanks just solved my problem, hope developers clear this bug.. – emtin4 Feb 20 '12 at 10:49


gsettings set org.gnome.desktop.interface toolkit-accessibility false

It worked for me.

share|improve this answer
yup....... this link follows to the answer in the bug discussion of Synaptic at launchpad – syedrakib Nov 5 '11 at 1:39

protected by Community Nov 29 '11 at 22:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.