Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem:

My PC on campus sits behind a proxy (requiring authentication) and I can't setup Dropbox. I am convinced that this is a proxy issue as I can't setup Ubuntu one either (but I don't use Ubuntu One so that is not a problem). I have looked at the Ubuntu One fix but it seems to be to modify settings explicitly related to Ubuntu One. I can install the nautilus-dropbox package (compiled from source and from .deb package from website and from software centre) but once I click OK from the "Dropbox Installation" dialog box (prompting me to download the proprietary daemon) the installation just freezes with the OK button pressed. When I look at its process in System Monitor its waiting channel is inet_wait_for_connect.

I have set the following proxy directives thus far:

  1. Added mj22:**@proxy.waikato.ac.nz:80 information to network proxy settings under network in settings.
  2. Added http_host and http_port variables under gconf-editor->system->proxy
  3. Added 'host', 'authentication_password' 'authentication_user' and ticked 'user authentication' and 'use_http_proxy' under gconf-editor->system->http_proxy
  4. Added export http_proxy="http://mj22:**@proxy.waikato.ac.nz:80/" to /etc/bash.bashrc
  5. Added Acquire::http::proxy "http://mj22:**@proxy.waikato.ac.nz:80/"; to /etc/apt/apt.conf (which is what I imagine is letting Software Center retrieve packages).

(where ** is my password)

I have also added the equivalent ftp and https lines for the above entries. I get the internet fine and Software Centre can download packages but thats it.

Related issues:

  1. The software centre can't fetch reviews (but can download packages).
  2. When trying to add an online account in Gnome 3 a dialog pop up appears with "Error getting a Request Token: Cannot connect to proxy (proxy.waikato.ac.nz)"

Updates:

After some time (10mins ish) Dropbox shows an error dialog box that reads:

Trouble connecting to Dropbox servers. Maybe your internet connection is down, or you need to set you http_proxy environment variable.

Is there a way I can see what environment variables are currently set?

share|improve this question
    
Running env in terminal should show you environment variables. Is http_proxy set there? If not you could try adding it with export http_proxy="mj22:**@proxy.waikato.ac.nz:80/" –  kikixx Oct 19 '11 at 21:10
    
@kikixx. Yes. env shows both http_proxy=mj22:**@proxy.waikato.ac.nz:80/ and ftp_proxy=mj22:**@proxy.waikato.ac.nz:80/ are set. Should they appear with quotation marks as shown by env? –  Mark Jones Oct 20 '11 at 0:41
    
Sorry Mark, it looks like the proxy settings are in a bit of a state in 11.10. After "applying system wide" can you check /etc/environment and confirm it is in there also? Last suggestion from me is to add the http_proxy variables to /system/proxy and /system/http_proxy in case it is checking legacy values. –  kikixx Oct 20 '11 at 9:23

4 Answers 4

up vote 10 down vote accepted
sudo http_proxy=http://your_proxy:proxy_port dropbox start -i

or

sudo https_proxy=http://your_proxy:proxy_port dropbox start -i

You have to run the deamon as root, and thus, you have to configure the proxy as root. Setting the http_proxy root env variable on invocation should be enough.

share|improve this answer
    
Excellent, this did the trick. Thank you. –  Mark Jones Nov 3 '11 at 2:21
    
This didnt work for me... but Ingo Karkat solution did it :) –  zipizap Jan 8 '13 at 17:18
    
As of Feb-2014, http_proxy doesn't works, since the binary is expected to be downloaded from a secured web server. So https_proxy should be the right variable to use. –  Raja Varma Feb 27 at 8:19
    
Awesome! Thank you –  Wellington Lorindo Nov 12 at 17:06

What is still missing is the installation of the Dropbox daemon. You can download and install it manually; this is documented at https://www.dropbox.com/install?os=lnx

32-bit:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -

64-bit:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

Next, run the Dropbox daemon from the newly created .dropbox-dist folder.

~/.dropbox-dist/dropboxd
share|improve this answer
    
it worked :) thanks –  zipizap Jan 8 '13 at 17:19

In case it helps anyone, I had an issue with the proxy settings and although I had them set they weren't enabled:

You can see if they are enabled like this:

gsettings get org.gnome.system.proxy.http enabled

And enable them if they aren't like this:

gsettings set org.gnome.system.proxy.http enabled true
share|improve this answer

In case someone uses proxy that requires authentication:

sudo http_proxy=http://username:password@proxyhost:proxy_port dropbox start -i

worked for me!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.