Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I push the shutdown button in the shutdown dialog my notebook (Lenovo X220) does a restart instead.

I also tried running the "sudo shutdown -P now" from command line -> same result!

Before upgrading to 11.10 everything was fine.

Anybody else experiences this malfunction? Any tips to make it work again?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I'm here on Xubuntu 11.10 with an x220 i5 and experienced the same issue.

Installing laptop-mode-tools (with aptitude install laptop-mode-tools --without-recommends) fixed it for me.

(found the hint via https://answers.launchpad.net/ubuntu/+source/acpi/+question/168617)

I came up with another solution that does not involve laptop-mode-tools. Maybe it works for others. The problem seems to occur when power-management for PCI(e) devices is enabled (set to "auto"). Here are two ways to check that:

  1. run powertop, switch to the "Tunables" tab and see if your "Runtime PM for PCI*" entries are marked as "Good"
  2. cat /sys/bus/pci/devices/*/power/control and see if it outputs some "auto" values. "auto" causes the shutdown problems on my machine while "on" does not.

I created an init.d script to handle that (and other stuff like setting battery charge threshs and the like), available via pastebin.

Note:

  • The script runs fine on my machine. This does not mean it will run on others due to missing programs, etc.
  • The script does more than (potentially) circumventing the shutdown problem, so please read it first.
  • I am not sure that "auto" brings any benefit at all ;)

Hope it helps.

share|improve this answer
    
I executed the recommended command. It said that laptop-mode-tools is already installed but somehow now it works! Thank you for the advice! –  lebenlechzer Nov 1 '11 at 10:31

I have laptop-mode-tools installed but the problem occurs anyway. Oneiric with gnome/unity, on an i7 x220. Happens whether I do sudo shutdown -h now or shutdown via the gui. My only workaround is to hold the power button after reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.