Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i recently updated my ubuntu from 11.04 to 11.10 today, in this i know that it is with kernel 3.0 now after installation when i rebooted my system.i had the same old kernel so i dig in to it and found out that my boot menu was not getting updated!! then i saw my /boot dir and found that i had and all versions but my grub2 is not updating boot menu!! what to do? i tried boot-repair,grub customizer and also reinstalled grub2 but i m still unable to fix this issue!! so can u suggest any solution and yes i m not very command line friendly :)

hint:- i tried command

sudo update-grub


sudo grub-mkconfig -o /boot/grub/grub.cfg

but both say "syntax error"

DOUBT:- i experimented BURGE boot-loader 7 to 8 months back!!was working well but it broke my plymouth so i removed it.but i think since then my kernel header is not being updated!! so could it be the coz of my problem? :)

sorry4such long post,but i thought this details might help u find some solutions thanks bye.. :(

share|improve this question

closed as too localized by fossfreedom Mar 4 '12 at 12:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) – fossfreedom Mar 4 '12 at 12:31

Yes, that could be the problem. BURG overwrite your GRUB configuration in MBR and so you MUST repair it to make it work again.

You should repair your grub following this guide (also if you didn't install Windows) and then everything will be fine.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.