Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Gnome shell calendar menu, when I click on "Open Calendar" it tries to open Evolution - even if it's not installed - Is it possible to change the default calendar?

Gnome Shell Calendar


P.S. Gnome shell Calendar does not follow default calendar application

share|improve this question

5 Answers 5

Type the following in a terminal.

For Thunderbird:

gsettings set org.gnome.desktop.default-applications.office.calendar exec thunderbird

For Chromium

gsettings set org.gnome.desktop.default-applications.office.calendar exec "chromium-browser 'https://www.google.com/calendar'"
share|improve this answer
    
i tried it and it works! thanks –  suli8 Oct 22 '11 at 18:00
10  
it do open the lightning calendar, but it does not sync the calendar itself and the tasks! –  suli8 Oct 22 '11 at 18:41

In Gnome 3.8 use gvfs-mime to manipulate calendar mime association:

Inspect:

gvfs-mime --query text/calendar

set your app:

gvfs-mime --set text/calendar google-calendar.desktop

whereas google-calendar.desktop can be created like this:

gnome-desktop-item-edit --create-new ~/.local/share/applications/google-calendar.desktop

Then fill the dialog with the following as a command to open browser with google calendar:

xdg-open https://www.google.com/calendar

Then restart gnome-shell or logout/login to reload the settings.

share|improve this answer
    
I do not seem to have the gnome-desktop-item-edit command available –  Piero Jan 29 at 11:03

I repost this from a user named Wonder

[edited slightly] Thunderbird is not a calendar application unless you tune it up with an extension. therefore it shouldn't be in there, but... if you really want it there,you need to perform the following two steps (as root).

# vi /usr/share/applications/mozilla-thunderbird.desktop  
# update-desktop-database -q

In editing the desktop file, append the Mimetype line with text/calendar;text/x-vcard;

MimeType=message/rfc822;x-scheme-handler/mailto;text/calendar;text/x-vcard;

I tried this, the app does show up, but I have not seen the calendar menu widget synch.

share|improve this answer

Since this is still (like two years later) a problem I had to google, here is a fiddly workaround for anyone else trying to set up Lightning in place of Evolution and if the Evolution-mirror plugin does not work for you (has not been updated since last year at this point). Unfortunately you still need to have Evolution installed.

Create a network ics calendar in a local file (or wherever you like) using either Evolution or Lightning. Point both Evolution and Lightning to it and any changes made in Lightning will be reflected in the calendar menu (events for today and tomorrow).

Combine that with answer #2 above to change the "open calendar" to point to Thunderbird and you'll (hardly ever) have to look at Evolution again!

share|improve this answer

open system settings in the upper right and go to system info then default applications and change it there!

share|improve this answer
1  
thanks, but it doesn't affect on gnome shell calendar –  Behzadsh Oct 19 '11 at 16:25
2  
This also doesn't work at the moment due to bug 841409. –  WarriorIng64 Oct 25 '11 at 5:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.