Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After fighting Nvidia optimus too long, I've decided to give up and try to just get 3d working, using any way. I've tried out Fedora 15, which actually worked for my computer -- nice 3d graphics, recognised my intel card and used the driver. I'm trying to install the intel graphics on a 11.04 alienware M11x. First step I figured would be disabling nvidia, but using sudo echo "blacklist nouveau" > /etc/modprobe.d/blacklist-nvidia.conf says permission is denied (Yes, I definitely used sudo). Any suggestions how to do this?

System: Alienware M11x R3 [8gb ram, Intel Core i5-2537M 1.4GHz (2.3GHz Turbo Mode, 3MB Cache), NVIDIA GeForce GT540 graphics with 1.0GB Video Memory and Optimus]

share|improve this question
1  
As to why sudo didn't work: It just applies to the echo "blacklist nouveau" part; the > /etc/modprobe.d/blacklist-nvidia.conf part is still being executed using your normal user permissions; see stackoverflow.com/questions/82256/… –  daniel kullmann Oct 20 '11 at 7:08
    
did you try a recent version of bumblebee? –  213441265152351 Jun 9 '12 at 15:10
add comment

3 Answers 3

up vote 1 down vote accepted

You cannot disable the Nvidia card by default, it's hardwired to the Intel CPU. You had 3D issues because the card could not be used, but the drivers were still loaded, preventing the Mesa OpenGL module from being loaded. This breaks graphical effects, 3D capabilities and such. Uninstalling the nvidia driver reverts this behavior.

Your sudo echo command failed because of sudo & redirect output

Optimus is not supported by nVidia for Linux. For a longer explanation and possible workarounds, see How well do laptops with Nvidia Optimus work?

share|improve this answer
    
Thanks, the echo tip was nice (though I found I have no ./vgaswitcheroo folder, which I could not make). Not sure whether I've disabled it, but disabling the proprietary driver worked for me; got 3D now and very happy. –  Wane5tars Oct 20 '11 at 16:45
1  
I've no vga switcheroo folder either, but it's unlikely going to work since it was designed for laptops with a mux for switching between the intel and nvidia cards. Your card is still on and sucking about 20% power without being useful. In the near future, the ACPI devs from the Bumblebee Team (me and ArchangeGabriel) may have created a script for detecting the right methods for turning the card off (and on). –  Lekensteyn Oct 20 '11 at 19:10
add comment

Got it working, or at least, 3D. Just had to disable the propietary driver through the Drivers application. I way overthought this.

share|improve this answer
add comment

First type sudo su in the terminal, then everything you write will be in sudo mode. And then type echo "blacklist nouveau" >> /etc/modprobe.d/blackist.conf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.