Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu newbie here.

I had Ubuntu for a while now, since 10.04 (Lucid Lynx), and I was getting very comfortable at installing / uninstalling and finding my way through stuff. Loved the cube etc.

Then came along 11.04, the great natty narwhal, and I could no longer have my desktop cube, but after using it for a while I really got used to the so called "hot corners", where it shows all desktop if mouse hits screen top left (0,0), all windows at top right, and show desktop at bottom right. I am so used to it that ubuntu is unusable now without it, after the 11.10 upgrade. I cannot get it to work no matter how hard I Try.

How do I go about getting them back? Why did Ubuntu stop hot corners? It was so amazingly useful!

I've only used ubuntu for basic tasks because it was a nightmare getting my wacom table to work on it. So please give the complete details necessary,

thanks.

share|improve this question
3  
Ubuntu doesn't ship hot corners by default, you must have set these up at some point. –  Jorge Castro Oct 19 '11 at 13:53
    
@JorgeCastro, really?! I am confused. I don't remember setting these up myself. that's strange. How do I set up hot corners, then, please? –  iamserious Oct 19 '11 at 14:11
1  
I don't know how, but hopefully someone will come along, just keep improving your question with things you've tried, etc. –  Jorge Castro Oct 19 '11 at 14:13
    
@Jorge you were right! I had after reading the answers, I remember setting this up myself! Facepalm moment!thanks! –  iamserious Oct 19 '11 at 21:03

3 Answers 3

up vote 2 down vote accepted

More than likely you used Compiz Config Settings Manager to set up your hot corners. There are other applications, but since you seem to be using Unity I won't go into all of that.

In general, setting up a hot corner is dependent on the particular plugin/feature that you want to activate (in other words you have to choose the hot corner from the plugin's settings).

An example:

  • Open Compiz Config Settings Manager.
  • Open the Widget Layer Plugin's settings.
    Widget Layer Plugin
  • Click on the "none" next to Toggle Widget Display.
    Hot corners
  • Choose a hot corner (screen edge), and close the dialogue.
  • Try your new hot corner, and change it if you like.

NB:

The same method works for other plugins that support hot corners, including showing the desktop (in general options), activating scale mode (globabally), etc.

share|improve this answer
    
Hi, I am out now, will try this out as soon as I get back on my machine and let you know, thank you very much! –  iamserious Oct 19 '11 at 16:14
    
Hi, thanks, followed through and I got it working right back! –  iamserious Oct 19 '11 at 21:04

A lot of useful stuff can be set in the Compiz Config Settings Manager (ccsm). This can be installed by searching for "Compiz" in the Software Center. On the details page of compiz there's a checkbox to install the settings manager. If you aren't afraid of the command line, you can also install it far more easily by typing

sudo apt-get install compizconfig-settings-manager

in the terminal. Since there's no longer a link to ccsm in the sytem settings, start it manually by pressing ALT+F2 and typing ccsm [Enter]. Within this settings manager, under "common settings" (I think it's called like that, I run the german translation, there it's "Allgemeine Optionen") there's a tab called "key bindings". On this tab is a small screen icon next to "Show desktop". That's where you can assign a hot corner or border for "show desktop". To get an overview over all desktops, you use compiz' "Expo" Plugin. In its settings (also accessible in compiz config settings manager) you can set an "Expo edge". The overview over all windows is configured via the "scale windows" plugin of compiz, just the same way.

share|improve this answer
    
Hi, I am out now, will try this out as soon as I get back on my machine and let you know, thank you very much! –  iamserious Oct 19 '11 at 16:14

You have to install compiz config and then setup your hot corners. I recorded a video to help you out: http://madmed88.tumblr.com/post/12787461772/setup-hot-corners-in-ubuntu-compiz-unity

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.