Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I get two clocks in my Gnome panel with one being in my local time and the other being in UTC?

share|improve this question
    
It would seem this is just not possible in 10.10 the way I envision. I ended up creating my own indicator applet to do this. You can download it here if you are interested: ubuntuone.com/p/KIS Screenshot here: goo.gl/7V9w Now if I can just how to figure out how to control the order of the indicators. Another question to ask I think! –  Ramón Oct 14 '10 at 4:05
    
Hi Ramon, is there any other means to download your new indicator? For me, both the screenshot and the download links yield errors: - Ubuntu One download error >> i.imgur.com/6REjr.png - Screenshot error >> i.imgur.com/S2x9o.png I wondered if it uses true UTC time rather than GMT as well (I wish the Gnome clock applet did not use GMT)? Thanks! –  user10328 Feb 6 '11 at 21:47
    
Hmm, yeah the links are broken for me too. Weird. Try this one: paste.ubuntu.com/564989 Oh, and GMT and UTC are equivalent. GMT is just the old name for UTC. –  Ramón Feb 9 '11 at 14:26
add comment

3 Answers 3

up vote 10 down vote accepted

The GNOME clock applet, can't display two times on the panel, but it can show two times in the drop down.

alt text

Right click on the clock and select "Preferences." Goto the "Locations" tab and press "add."

Then, select "Greenwich Mean Time" from the "Timezone" list.

alt text

share|improve this answer
    
Thanks for your answer andrew. You are right about two clocks. I was able to have two clocks display but both applets crashed when setting them to different Locations. I'm going to keep looking for a solution before I accept your answer that it's not possible. Thanks again. –  Ramón Oct 13 '10 at 23:18
add comment

You can't do it with 2 clocks AFAIK (the clock always shows the time in the local timezone by default), but you can add extra locations in the drop-down menu of the clock applet so that seeing UTC is one click away (this is not yet possible with indicator-datetime though, although I think it's planned).

share|improve this answer
add comment

Try to install indicator-datetime

sudo apt-get install indicator-datetime

indicator-datetime will appear in Indicator applet in your tray icon, this applet for your local time,

and the old one just change the configuration in /apps/clock_applet/prefs/gmt_time with gconf-editor, for yuur UTC/GMT time.

share|improve this answer
    
Thanks for the suggestion but the time does not show up in the indicator applet after installing indicator-datetime. Not sure why. Also, the key I found was /apps/panel/applets/clock_screen0/prefs/gmt_time and it has the following description: "The use of this key was deprecated in GNOME 2.28 in favour of the use of timezones. The schema is retained for compatibility with older versions." Changing it does not change the displayed time. –  Ramón Oct 13 '10 at 20:01
    
@Ramón askubuntu.com/questions/6842/… –  Alvin Row Oct 13 '10 at 20:08
    
Thanks, it shows up now. Seems like there should be a package dependency somewhere in there :) Now about that UTC time... –  Ramón Oct 13 '10 at 20:09
    
@Ramón: about the dependency, indicator-datetime & indicator-applet-complete don't have a hard dependency (there are other applications that can show indicators, e.g. in KDE or other DE). –  JanC Oct 13 '10 at 20:31
add comment

protected by htorque Oct 25 '11 at 9:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.