Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Note: the answer I've accepted works correctly in Precise Pangolin (12.04). It does not work correctly in Oneiric Ocelot.

Original text:

I have an application in which I want to use alt-F1 to access some specific functionality. Unfortunately, Unity in Oneiric Ocelot (11.10) grabs this key combination and shows the launcher. I would like to disable or bypass that behavior, but I have no idea how to accomplish it.

I have read How do I deactivate F1 and F10 keybindings? and looked around in all the places pointed-out there and elsewhere, in both the CompizConfig Settings Manager and the gconf-editor. Unfortunately, the alt-F1 combination is nowhere to be found or disabled. In fact I have successfully prevented Gnome/Compiz from intercepting the keybinding in previous distributions (Lucid Lynx and older).

Can anyone tell me where I can prevent Unity from interpreting my keybindings before my application has a chance to respond to them?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

in ccsm (CompizConfig Settings Manager) > Ubuntu Unity Plugin it's sitting right there on the Behavior tab

share|improve this answer
    
Are you referring to the 'Key to put keyboard-focus on launcher'? It seems I've already set that one to 'Disabled'. Otherwise, I can't find any mention of <Alt>F1 (on the Behavior tab or elsewhere in the Ubuntu Unity Plugin settings). –  Confusion Oct 20 '11 at 6:03
    
It has been fixed in Precise Pangolin: setting the binding to 'disabled' or something different in ccsm solves the problem. –  Confusion Apr 28 '12 at 15:03
    
thanks, this did the trick, although I had to actually install ccsm. –  Espen Schulstad May 2 '12 at 9:29
    
There's another place in ccsm where you should disable it: ccsm > Gnome Compatibility > Show Main Menu –  wheleph Jan 15 '13 at 22:26

This is an ugly hack

edit, as superuser, the following file

/usr/share/compiz/unityshell.xml

and change

    <option name="execute_command" type="key">
           <short>Key to execute a command</short>
           <long>Key to open a folder or execute a command</long>
           <default>&lt;Alt&gt;F2</default>
    </option>

to something like:

    <option name="execute_command" type="key">
           <short>Key to execute a command</short>
           <long>Key to open a folder or execute a command</long>
           <default>&lt;Super&gt;F2</default>
    </option>

Logout and login.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.