Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While upgrading to Version 11.10 of Ubuntu, I noticed that the (aptitude) package libdjvulibre21 failed installation. After instllation, I was prompted that one package had failed installation, and that I execute the Package Manager, or run apt-get to rectify this problem. Running apt-get still did not resolve the problem. Instead, it produced the following log file.

vasilios@vasilios-OptiPlex-210L:~$ sudo apt-get -f install
[sudo] password for vasilios: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libpanel-applet-4-0 libswscale0 libavutil50 libgcj-bc libcamd2.2.0
  linux-headers-2.6.38-8 libftgl2 kalgebra-common libpostproc51 libpari2-gmp
  libavformat52 libgcj11 kalgebra linux-headers-2.6.38-8-generic
  gcj-4.5-jre-lib libsigsegv0 libavcodec52 gir1.2-panelapplet-4.0 gcj-4.5-base
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libdjvulibre21
The following packages will be upgraded:
  libdjvulibre21
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/706 kB of archives.
After this operation, 20.5 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 298010 files and directories currently installed.)
Preparing to replace libdjvulibre21 3.5.23-3ubuntu2 (using .../libdjvulibre21_3.5.24-8_i386.deb) ...
Unpacking replacement libdjvulibre21 ...
dpkg-deb (subprocess): data: internal gzip read error: '<fd:0>: data error'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing /var/cache/apt/archives/libdjvulibre21_3.5.24-8_i386.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
No apport report written because the error message indicates an issue on the local system
         Errors were encountered while processing:
 /var/cache/apt/archives/libdjvulibre21_3.5.24-8_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
vasilios@vasilios-OptiPlex-210L:~$ 

No matter how many times I execute apt-get I receive the same error messages. Judging by this log file. it would appear that the libdjvulibre21_3.5.24-8_i386.deb package that was downloaded during the installation is broken. Not sure how I can force a re-download using apt-get.

As an aside, this problem wouldn't have anything to do with the fact that I was trying to install OpenOffice under Ubuntu Version 11.04? In this case, even though the installation was successful, the LibreOffice icons were still being displayed on the side-bar, and the OpenOffice package was nowhere to be found on my system.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Remove the file /var/cache/apt/archives/libdjvulibre21_3.5.24-8_i386.deb and try again to install the package.

share|improve this answer
    
Thanks for that! It solved my problem! –  Bill Oct 19 '11 at 13:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.