Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Brand new installation of Ubuntu 11.10 and then install the nvidia proprietary driver (280.13) by selecting "Additional Drivers" -> driver activated and used (according to the same menu). When I type "glxinfo" in a terminal I get this error:

X Error of failed request:  BadWindow (invalid Window parameter)
Major opcode of failed request:  137 (NV-GLX)
Minor opcode of failed request:  4 ()
Resource id in failed request:  0x5400003
Serial number of failed request:  32
Current serial number in output stream:  32

"lspci | grep VGA" gives:

02:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8500 GT] (rev a1)

Before this upgrade I was on a 11.04 perfectly functional and fluids with 3D effects ... Also, I work with dual screen (configured with nvidia-settings) and when I select the menu "glx information" nvidia-settings crash ... I don't understand these errors because my environment was functional prior to "clean" installation...

Do you have any ideas ? People in the same situation? Thank you in advance for your help.

share|improve this question
add comment

2 Answers 2

Much the same thing just happened to me (running 10.04) after the most recent Ubuntu kernel update. I looked at glxinfo after seeing the same xsettings crash.

I did the following:

  1. change to a terminal;
  2. sudo service gdm stop
  3. sudo apt-get remove nvidia*
  4. ./NVIDIA-Linux-x86_64-285.05.09.run to run the installer - I did not choose to add the 32-bit compatibility stuff on my 64 bit machine this time - there were a bunch of warnings about directories not existing;
  5. sudo service gdm start
  6. log in normally;
  7. go to 'Preferences:Appearances:Visual Effects' and select 'Extra' - it worked this time;
  8. re-import Compiz settings; and I am good to go again - until the next kernel update?

But after doing the above, when I rebooted I came up in low-graphics safe mode. Trying to run the nvidia-xconfig or nvidia-installer (I forget which), it complained that the 'nouveau' drivers were installed, and asked if I wanted to have the program try to disable that by inserting a file in /etc/modprobe.d/ . I agreed. After rebooting, everything came up great so all's well.

share|improve this answer
    
Following some additional rummaging around, I resorted to the following: –  Gary B Oct 21 '11 at 14:32
    
I did the following: 1. change to a terminal; 2. 'sudo service gdm stop'; 3. 'sudo apt-get remove nvidia*; 4. './NVIDIA-Linux-x86_64-285.05.09.run' to run the installer - I did not choose to add the 32-bit compatibility stuff on my 64 bit machine this time - there were a bunch of warnings about directories not existing; 6. 'sudo service gdm start'; 7. log in normally; 8. go to 'Preferences:Appearances:Visual Effects' and select 'Extra' - it worked this time; 9. re-import Compiz settings; and I am good to go again - until the next kernel update? :P –  Gary B Oct 21 '11 at 14:47
    
Argh. After doing the above, when I rebooted I came up in low-graphics safe mode. Trying to run the nvidia-xconfig or nvidia-installer (I forget which) it complained that the 'nouveau' drivers were installed, and asked if I wanted to have the program try to disable that by inserting a file in /etc/modprobe.d/. I agreed. After rebooting, everything came up great so all's well. –  Gary B Oct 21 '11 at 14:58
    
Gary, I've added your comments to your answer. –  belacqua Oct 21 '11 at 20:02
add comment

I added the depot "ppa:ubuntu-x-swat/x-updates" to install the latest driver (285.05.09). The driver is activated and used, but I still get the same error with glxinfo... Any ideas ? Is this could be related to dual screen (a problem of config in xorg.conf)?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.