Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 11.10 yesterday, and since then the hgsubversion extension of mercurial no longer find the python bindings.

abort: no compatible bindings available:

Subversion 1.5.0 or later required, but no bindings were found
Subvertpy 0.7.4 or later required, but not found

Please install either Subvertpy or the Subversion Python SWIG bindings!

However, both this packages are currently installed (version 1.6.12dfsg-4ubuntu5 for python-subversion and version 0.8.3-1 for python-subvertpy).

Initially I was using hgsubversion pulled from their mercurial repository, which I had to update following mercurial update, so I'm now at revision 836 (October 12th). As I saw there was now a package for hgsubversion in the repository (don't know when it has been added), I tried with that version as well, but to no avail.

So far, here's what I tried to fix the problem or help diagnose:

  1. I reinstalled subversion, mercurial, python and both bindings package.
  2. I noticed I had python 2.6 and python 2.7, so I removed python 2.6.
  3. Forcing the use of Subvertpy with HGSUBVERSION_BINDINGS="Subvertpy": abort: Subvertpy 0.7.4 or later required, but not found!
  4. Forcing the use of SWIG bindings with HGSUBVEERSION_BINDINGS="SWIG": abort: Subversion 1.5.0 or later required, but no bindings were found!
  5. Tried using alternatively both the Ubuntu package version of hgsubversion (1.2.1-2.1) and the latest version pulled from hgsbuversion repository.

Does anyone know why would that happen and what should I have to do to fix it?

Thank you.

Edit: forgot a few version informations

python --version
Python 2.7.2+

package version: 2.7.2-5ubuntu1

hg version
Mercurial Distributed SCM (version 1.9.1)

package version: 1.9.1-1ubuntu0.1

share|improve this question

2 Answers 2

On HgSubversion wiki you can read :

The easiest way to install hgsubversion is to just clone the hgsubversion repository and then configure Mercurial to use it. Cloning the tip is recommended as it is much more stable than the latest tag 1.2.1 from march 2011.

Clone the repository :

$ hg clone http://bitbucket.org/durin42/hgsubversion/ hgsubversion

All tests passed :

$ nosetests
Ran 493 tests in 1400.680s

OK  

Check that HgSubversion is installed and properly activated :

$ hg version --svn
Mercurial Distributed SCM (version 1.9.1)
(see http://mercurial.selenic.com for more information)

Copyright (C) 2005-2011 Matt Mackall and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

hgsubversion: 3292ff0380f3
Subversion: 1.6.12
bindings: Subvertpy 0.8.3
share|improve this answer
    
Wasn't that. I was already using the latest revision from hgsubversion update October 12th), and had even tested again after updating to 1.3 to no avail. Finally found the cause though, which I added as an answer. –  Gorkk Oct 20 '11 at 13:33
up vote 0 down vote accepted

Finally found the cause: it was coming from the line in my hgrc defining the use of the hgview extension.

After the upgrade, my old hgview= line to activate failed (it wouldn't find the extension), and I had replaced it with hgext.hgview=/usr/share/pyshared/hgext/hgview.py after having located it.

As there was no longer any hgview related error in the log afterwards, I didn't think much about it. However that was the cause of my hgsubversion not finding the bindings, though I still don't know why.

Thus, removing that line in my .hgrc file solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.