Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my Thinkpad T60 from Ubuntu 11.04 to 11.10. My wireless worked on 11.04 without a problem. Using 11.10, it detects all the wireless networks available, but will not connect to it. It does however connect to any non-encrypted network. My wireless network uses WPA2-Personal.

The problem is not my wireless network, as my other devices can connect to it properly.

How can I get my Thinkpad T60's wireless working again on 11.10?

The wireless interface is a PRO/Wireless 3945ABG [Golan] Network Connection from Intel Corporation.

Threads I'm following on Ubuntu Forum:

I posted a Wireless issue too:

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The issue was discussed and solved on on the Ubuntu Forum here.

The problem is with the network manager.

  1. Install wicd using Synaptic or software center.
  2. Remove network manager using: sudo apt-get purge network-manager network-manager-gnome

Then use wicd to connect to your wireless network using WPA2.

share|improve this answer
    
0 down vote not working this is not a solution its not working and i also try to downgrade to naty kernel and its also not working. maybe this is because of gnome3 integeration but no one did fix this i search all over the net no solution guys me going back to natty –  nadeem Nov 1 '11 at 11:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.