Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to Oneiric (from Natty) on my IBM Thinkpad X41. With the default CPU speed setting of "on demand" I get 100 % CPU usage.

  • In System Monitor (nb: view > all processes) the dominant process is Xorg with 60 - 70 % CPU usage (and 13.7 MiB),
    • followed by gdl-box with about 20-25 % and gnome-system-monitor with about 20 %.

Was it a mistake to upgrade to Oneiric? How can I fix this? I now set the CPU speed manually to 1 GHz - but that can't be the solution...

Not very happy...

Thank you.

share|improve this question
    
Sometimes it happens, sometimes it doesn't. Just now I shut down completely, did a cold reboot: back to normal. But this is not reliable at all yet. Would it help to post the running processes from "top" and "ps aux" here? –  nutty about natty Oct 20 '11 at 11:53
    
Just (cold) rebooted again - xorg is fine. A further preliminary observation: Once ubuntu's booted and I'm logged in, xorg is either fine or not; once that's decided, that state is steady and doesn't change until after a reboot. –  nutty about natty Oct 20 '11 at 12:38
    
I used wine, skype, went into standby, woke up, ... it seems stable (as described in the previous comment) ... let's wait and see! –  nutty about natty Oct 20 '11 at 12:47
    
3rd (cold) reboot in a row - xorg is fine. Just applied the font corruption fix which I had postponed for Oneiric. –  nutty about natty Oct 20 '11 at 13:24
    
More often than not, xorg seemed fine in the end; however, I still went back to natty, as a calc file would take 1.5 minutes to load (instead of 3-4 seconds in natty). Also didn't like some of the changes, such as Alt-tab, etc. Hence, I'm back to natty until the release of 12.04 LTS (Precise Pangolin): then I'll try a fresh install... –  nutty about natty Oct 22 '11 at 17:00
add comment

6 Answers 6

Luckily for you, high X.org CPU usage doesn't mean you have a bug in X, so this problem is likely something you can solve.

X is a server, which means it responds to client requests. If a client has lost its mind and is making excessive X calls (such as if it locks itself into a graphics updating loop), it can make a lot of X calls. This shows up as a high X CPU load.

So, the thing to look for is to identify which client program is causing the load. Often it is a program you don't realize is even running - perhaps a panel indicator or background task or service. Look through your process table for user processes that look out of place, and try killing them one by one until the load goes down. Then you know what caused it.

Alternatively, log into a guest account; verify the load is normal there. Compare your processes in the guest account with those in your regular account, and go from there.

While high X cpu bugs are not at all unusual, I have not seen many reported in oneiric, so I might guess that the faulty process is some unusual program not installed by default; perhaps something you manually installed previously that got automatically upgraded to a new version that has a bug in it? Anyway, good luck in your hunt.

share|improve this answer
    
Thanks Bryce, I appreciate your input! –  nutty about natty Oct 20 '11 at 12:00
    
So brittle a design this is... any program could be hogging Xorg with impunity. –  Prof. Falken Nov 23 '12 at 9:06
add comment

in my case it is gdl_box the tray program of google desktop search, causing high cpu loads since i upgraded to oneiric amd64 from natty amd64. after killing that process everything is fine cpu load and temperature going down immeadiately. as i was not able to find a solution i switched from google desktop search for linux to tracker and tracker-needle. to me it is not so satisfying as google desktop search but i can live with it. would be nice from google to update it one day but from a german computer magazine i read that google is going to cancel a lot of services which includes their desktop search. what a shame...

greetings

peter

share|improve this answer
add comment

I sometimes have high X CPU loads caused by Firefox. Restarting Firefox solves the problem.

share|improve this answer
add comment

I had this problem in my desktop & laptop (HP nx7300) with Intel. Could you try this? sudo apt-get install compizconfig-settings-manager ccsm Search openGL, and disable all checkboxs. Reboot. Enjoy again this version :)

share|improve this answer
add comment

Lowering gdl_box process priority seems to solve the high CPU usage problems on my Ubuntu 11.10.

Just in case anyone is interested in, I ran Google Desktop Linux with the following scripts placed in the 'Autostart':

#!/bin/sh
/opt/google/desktop/bin/gdlinux start
sleep 2
renice +10 `pgrep gdl_service`
renice +15 `pgrep gdl_config`
renice +20 `pgrep gdl_box`

Also make sure that the 'gdlinux' is NOT whitelisted in the Unity panel's system tray:

dconf-editor screenshot:

dconf-editor screenshot

share|improve this answer
add comment

I had the same problem with a long-running scp task . It was shown as an /usr/bin/xorg task, although scp (secure copy) did all the work. After it finished, CPU usage went down to normal. Even minimizing the terminal window helped reducing CPU load.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.