Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I open gnome-tweak-tool, go to the Theme section and choose the DMZ-Black cursor theme, my default cursor stays exactly the same. However, the other cursor images (like when I move a window or hover over a link) are the correct ones from the DMZ-Black theme. The same happens if I choose the Adwaita theme, for example.

Does anyone know why this is? How can I completely change my cursor theme so that the default cursor is also changed?

share|improve this question
up vote 7 down vote accepted

Multi-user 14.04

If you have only one user on your system, it will be ok to change default curser theme, whether by copying DMZ-Black contents onto DMZ-White, or changing default index.theme content, or even using command sudo update-alternatives --config x-cursor-theme.

But on a multi-user system, you need to personalize for yourself alone without affecting other users. Well, it's not so hard. You just need to make a "default" curser theme under your home.

Let's change the cursor theme in steps:

Via Terminal

  1. gsettings set org.gnome.desktop.interface cursor-theme "DMZ-Black" – simply replace "DMZ-Black" with your desired theme
  2. mkdir ~/.icons/default
  3. gedit ~/.icons/default/index.theme
  4. copy the following lines in the text file and save it:

    [Icon Theme]

    – again replace "DMZ-Black" with your desired theme.


  1. Install Dconf Editor or Unity Tweal Tool to be able to change the cursor theme;
  2. On Dconf Editor, search for "cursor-theme", double click it and change the value to "DMZ-Black" or your desired theme.

    Change mouse cursor theme via Dconf Editor

    Alternatively on Unity Tweak Tool under Apearance, go to Cursors and select "DMZ-Black" or your desired theme.

    Change mouse cursor theme via Unity Tweak Tool

  3. Open Files (Nautilus) and go to ~/.icons (make one if there isn't any);

  4. Make a new folder, name it default and open it;
  5. Make an empty document and name it index.theme;
  6. Open the file, paste the following lines and save it:

    [Icon Theme]

    You can replace "DMZ-Black" with your desired theme.

    Default cursor theme

This works also on Synaptic Package Manager and Nautilus with root privileges.

Source: Raschix's comment on a post from 4 years ago!

share|improve this answer
The terminal method worked for me in Ubuntu Studio 15.10 when the selected black pointer from the mouse preferences would switch between black and white depending on the window beneath. I had to create the directory ".icons" first however with: mkdir ~/.icons – Prototype700 May 1 at 23:23

In a terminal enter this:

gksu gedit /usr/share/icons/default/index.theme

Then change DMZ-White with exact name of the theme you want use, in your case DMZ-Black. Then it will show the correct theme.

share|improve this answer
Thank you! That solved my problem. I learnt I can also change that by using sudo update-alternatives --config x-cursor-theme. – Dylan McCall Oct 20 '11 at 1:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.