Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my 2010 Macbook Air, tapping on the touchpad works on about only half of the tap attempts. It seems the sensitivity or something is off. How can I fix this?

It looks like this question has been asked before and is unanswered.

share|improve this question
Looks like this is fixed in Precise 12.04 by default (i.e. it works with no xorg.confg or synclient scripts). – Luke Hoersten Mar 25 '12 at 23:16
up vote 2 down vote accepted

First, make sure you got the mactel extras: (Adding this PPA to your system)

After having those installed, type in the following commands in your terminal (ctrl-alt-t)

synclient FingerHigh=120
synclient FingerLow=45
synclient PalmDetect=1

This makes the touchpad work much better for me :)

share|improve this answer
Just changing to the latest synaptics driver from "multithouch" seemed to work though with your settings, it seems to work perfectly. Thanks a lot! – Luke Hoersten Dec 17 '11 at 21:39
The synaptics driver seems way more spotty than the multitouch driver. @Snicksie, do you have problems with the sensitivity of the synaptics driver? – Luke Hoersten Dec 19 '11 at 1:42


Create a file in /etc/X11/xorg.conf.d named 60-synaptics.conf

Section "InputClass"
  Identifier "touchpad"
  Driver "synaptics"
  MatchIsTouchpad "on"
  MatchDevicePath "/dev/input/event*"
  Option "FingerHigh" "50"
  Option "RTCornerButton" "0"
  Option "RBCornerButton" "0"
  Option "MinSpeed" "0.7"
  Option "MaxSpeed" "1.7"
  Option "SHMConfig" "on"
  Option "TapAndDragGesture" "off"
  Option "PalmDetect" "on"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.