Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UPDATE: The previous title for this question was "How To Specify Bitrate, Codec and Demultiplexing for VLC Video Capture or Recording."

I capture video from old TV tuner card - Pinnacle PCTV - using VLC. The video is from the Composite input and audio is from I guess the mixer or Line in. The command I use is:

vlc  v4l2:///dev/video0:normal=pal:width=720:height=576:input=1 :input-slave="alsa://hw:0,0"

In VLC, I have enabled the Advanced Controls toolbar, which allows me to record videos when I want to. However, these videos are uncompressed - very big and play only with VLC. Totem throws the "Could not demultiplex stream" error. I need to convert them using WinFF to reduce their size and make them playable with Totem and other software.

My question is whether I can configure the recording settings - the codecs and the bitrate, and also get the stream demultiplexed. If I pass any -sout parameter with command I get a "Segmentation fault". I use 64-bit Ubuntu 10.10.

share|improve this question
add comment

1 Answer

In the past I've had the following work for me:

ffmpeg -f oss -ac 2 -ar 48000 -i /dev/audio1 -acodec pcm_s16le -f video4linux2 -s 720x480 -r 3000/101 -i /dev/video0 -sameq -aspect 4:3 -target ntsc-dvd a.vob

Of course both the -target and frame rate -r 3000/101 would have to be changed for PAL.

share|improve this answer
    
Unlike VLC, ffmpeg does not allow me to view the video while I am recording. When VLC records it, it records everything uncompressed. –  Subhash Jul 6 '12 at 19:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.