Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently upgraded to Oneiric and am having a strange printing problem. I can print just fine from Evince, Firefox, and presumably all programs that use the standard Gnome printing backend (as evidenced by the Gnome print dialog). But when I try to print from LibreOffice, the printer spits out the following error message followed by a blank page:


The printer is a Samsung SCX-7423P using the generic PostScript driver. Everything worked fine under Natty.

Any ideas as to the cause of this problem, and more importantly, how to fix it?


Here's some additional information based on testing I did in response to @scottl's answer below:

  • I've tried three Oneiric boxes and only this one exhibits this problem. Unfortunately, it's a shared machine, so the impact is significant.
  • Exporting to PDF via either the toolbar button or the print to file option produces a file that Evince prints fine.
  • If I print to file and arrange for the filetype to be PostScript instead of PDF, I get the same error when printing on the affected machine using Evince. If I open the file on another machine and print it, everything is OK except that the font doesn't look quite right. I've posted an example PostScript file.
  • Even though the error output above mentions the font Times New Roman, the font isn't significant. The PostScript test was done using the font Ubuntu, and the error was the same except for the font name.
  • All testing was done using the same printer, as it's the only printer I have access to.
share|improve this question

closed as off topic by belacqua, James May 23 '12 at 17:48

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Maybe this bug report would be helpful to you. There seem to be problems regarding TTF Fonts with LibreOffice in Oneiric. – tohuwawohu Oct 20 '11 at 8:44
@tohuwawohu: Thanks. That's a good lead, but my other machine doesn't have the same problem, so that leads me to believe that there are some configuration issues at play, as well, or instead. – Scott Severance Oct 26 '11 at 11:25
oneric had a LOT of unsolved bugs. printing, kdenlive, compositing. i think it's due to the overriding focus on unity...but i digress. – RobotHumans Dec 12 '11 at 0:15

Try going to File -> Printer Settings -> Properties -> Device -> Printer Language and if it is set to PDF change it to PostScript.

To make this change stick:

  1. Make a document with this format and go to File -> Templates -> Save.
  2. In the new template type the name you want for it.
  3. In the list Category, select "My Documents" and click OK.
  4. Next choose File-Templates-Manage in the list templates, double-click the folder "My Templates".
  5. In the context menu, select the command "Set as default template" and close the dialog box.

The model is now used as the default template. Hope that works!

share|improve this answer
Thanks for the suggestion, but changing the printer language had no effect. – Scott Severance Dec 10 '11 at 0:18
That's all I can think of sorry. I hope you get it worked out. – Jakehero Dec 10 '11 at 2:00

It looks like this bug (actually caused by a badly pirated font), though that should be fixed in ghostscript 9.04 which is the version in oneiric.

Please upload an example postscript file illustrating the issue:

Where did you get the font from, since Times New Roman is not installed in Ubuntu by default?

share|improve this answer
Thanks. Your answer isn't correct because I'm using gs 9.04. However, I've done some additional testing in response to your answer and updated my question with the results. Hopefully they'll be useful. – Scott Severance Dec 13 '11 at 0:24
@ScottSeverance: Thanks for the additional info. Can you print if you click the Properties button for your printer in the print dialog box, go to the Device tab, and change the Printer Language Type? (e.g. to PDF) – scottl Dec 14 '11 at 2:35
No. That setting has no effect. – Scott Severance Dec 14 '11 at 5:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.