Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

AMD CCC crashes when I hit 'apply' after changing dual monitor settings


  1. I open AMD Catalyst Control Center
  2. I select 'Display Manager' on the left
  3. I choose the 'Multi-display desktop' Option
  4. I set both monitors to their max resolution (1920x1200 and 1600x1200)
  5. When I click the 'apply' button CCC closes without any sort of message (expecting it to tell me that a restart is required), and without (visibly) changing any settings.

Note: I copied the command line from the applications menu shortcut, and ran it from within a terminal window. When I click 'apply' it completes successfully, shows the message I'm used to, and the settings are applied next time I log in. This has happened to me before when attempting to find an error message printed to the terminal but instead the application works just fine. (the application was Minecraft)

share|improve this question
I noticed this same issue and also discovered the command line workaround you found. Since you already have the workaround I'm not sure what the question is. Sounds like you've got a good bug report written to send to AMD. – Carl Zulauf Oct 18 '11 at 23:28
For those of us who don't know where to obtain it w/o spending a chunk of time googling and hunting for it, just what is that command line? – DarenW Dec 11 '11 at 22:42
OMG, how could you not post the fix you found? !!!! – Chris Bauer Jan 23 '12 at 2:22
By the way, it's: gksudo amdcccle – Chris Bauer Jan 23 '12 at 3:05

I've run into this problem before with a couple of distributions and the recurring theme is that the /etc/X11/xorg.conf file doesn't exist. (Note: Once I was able to get Catalyst Control Center to run I tried deleting my xorg.conf file and re-running the program and was still able to click Apply and have it work, so it's possible I'm talking out of my arse).

I couldn't tell you the technical reason as to why this is a problem (or why X works without the file) but as soon as I create a generic file with:

aticonfig --initial

I'm able to run the Catalyst Control Center and make changes to my layout.

share|improve this answer

I realise this question is old but I found it while trying to solve my own problems, so I feel a lot of people in my situation will end up here too.

If you're using Ubuntu 12.04LTS and are having troubles getting your AMD/ATI graphics cards to work nicely with the AMD Catalyst Control Center you should check out this post about fixing the ATI driver installation. After following the instructions I can now happily use dual monitors.

share|improve this answer

I had the same issue in Lubuntu. I read on another forum about a quick fix that worked for me. I added the KDE desktop environment, restarted and used that desktop to set up multiple screens. When I hit apply it ask me if I wanted to save and I said yes and restarted to save my settings. I the logged back in under my LXDE desktop and had dual screens.

share|improve this answer

Run to AMD CCC, alternative command for gnome-terminal:

env LC_ALL=C amdcccle
share|improve this answer

I had the same issue when trying to get dual-screen working, but I was not ever able to get the GUI control center to work. I wound up using only aticonfig and the ubuntu displays configuration options (Ubuntu 12.04 here).

I have to combine a few things.

First: From the Unofficial linux AMD Ubuntu installation guide I ran the following two lines (backup your /etc/X11/xorg.conf file first!):

sudo amdconfig --initial -f
sudo amdconfig --set-pcs-str="DDX,EnableRandR12,FALSE"  

This re-initializes your config file, supposedly for dual screen. There are some other tips in that guide to get the driver to recognize xorg.conf and such, not sure if they're needed.

Second: I added a Virtual line to the subsection "Display" under the section "Screen" in my /etc/X11/xorg.conf:

Section "Screen"
    ... some stuff ...
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Virtual 3600 1200

Note that for me, the SubSection "Display" was already there, I just had to add the Virtual 3600 1200 line. I set this so that it represented the total combined resolution of my two screens. They had different heights, so I took the larger one (1200) for the y-direction. I need to add this to prevent the problem listed in Ubuntu bug #864505.

Finally: I rebooted (not sure if that was needed). Then, I went to the Ubuntu "Displays" configuration (NOT AMD's control center). Then I unchecked "Mirror displays". Reboot, and good to go with dual screens!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.