Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
open source ATI drivers not working

In the brand new Ubuntu 11.10 the drivers of ATI Radeon X1200 Series(RS690M) seems to be broken. Even when moving single window, it's barely moving. The drivers in 11.04 were working very well till the upgrade. When we can expect the thins working back again?

share|improve this question

marked as duplicate by nitstorm, jrg Feb 25 '12 at 14:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
did u fix it? I have the same issue: askubuntu.com/questions/91648/… –  Stann Dec 30 '11 at 21:38
    
An answer has been accepted at @Stann's question - Open Source ATI drivers not working. Hence voting to close this off as a duplicate –  nitstorm Feb 25 '12 at 9:41

3 Answers 3

I have also been pursuing this problem while running 10.10 on an eMachine D620 (x1250, RS690M chipset). I am using the radeon drivers from xorg-edgers-radeon ppa (http://ppa.launchpad.net/xorg-edgers/radeon/ubuntu).

Starting with Thomas's work, I was able to find a mostly working solution. The key enabler seems to be vsync_mode.

The first test that worked was running glxgears using the command line vsync_mode=0 glxgears. The result was going from ~10 FPS to ~150 FPS. (This is still not great, but a huge change.) To make this change permanent, I then ran driconf and set the option "Synchronize with vertical refresh" to "Never synchronize...". Logging out and back in made this take effect and solve 90% of my problems.

I have also applied changes from Thomas Wake into my /etc/X11/xorg.conf file. Here is what it looks like now

Section "Device"
        Identifier      "Configured Video Device"
        Driver   "radeon"
        Option  "DRI" "on"              #on is the default in recent radeonhd versions
        Option  "AccelMethod" "EXA"     #this is the default in recent radeonhd versions
#!used  Option  "EAXVSync"      "off"
        Option  "ColorTiling"   "on"
#!used  Option  "AGPMode"       "8"
#!used  Option  "AGPFastWrites" "on"
        Option  "EXAPixmaps"    "on"
        Option  "AccelDFS"      "on"
        Option  "RenderAccel"   "on"
#!used  Option  "DRI2"          "on"
        # from another source
        Option  "NoAccel"       "off"
#!used  Option  "EnablePageFlips"       "on"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen" 
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "CYonfigured Video Device"
EndSection

The lines starting #!used are options that are not used, but recommended by others from previous versions.

share|improve this answer

I have had this same problem with my Toshiba Equium P200D which has the RS690 radeon X1200 chipset and I now have the standard radeon driver to working, 3D and everything no problems.

To fix this I played with the radeon driver settings by adding the radeon-kms.conf file to the /etc/modprobe.d directory. Simply create the aforementioned file with the following entries:

options radeon noaccel=0
options radeon exavsync=0
options radeon colortiling=1
options radeon exapixmaps=1
options radeon enablepageflip=1

Hope this helps somebody else.

share|improve this answer
    
This caused errors with loading the radeon kernal module. (RS690M on a eMachines D620 laptop running 10.10). It did give me a clue. I ended up adding similar lines to xorg.conf and driconf (see answer). Thanks for the hints. –  jwernerny Jan 15 '12 at 13:45

yes, indeed. video hardware is not recognized by the latest catalyst that works with 11.10 and non-proprietary driver doesn't have a lot of features + because of video hang, computer don't resume from sleep

share|improve this answer
    
so - what can we do? –  Stann Dec 30 '11 at 21:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.