Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed the latest .deb Google Earth from Google, but the Google window is black (where the earth should be) Plus all 3D options are greyed out.

I have checked my graphics card, and 3D is enabled.

As shown here:

pst007x@pst007x-ubuntu64:~$  /usr/lib/nux/unity_support_test -p  
OpenGL vendor string:   Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string:  2.1 Mesa 7.11

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

I have never been able to get Google earth to work on Radeon, Nvidia and Intel cards.

I have followed installation instructions, but no luck.

What is odd that in the options menu, the 3D settings page is all greyed out, I am unable to select any option.

I have looked at other threads and no answers.

I have set my DNS to manual, ipv6 is off....

I am at a loss on this one...


I now get the error: We are unable to connect to the Google Earth servers

However I do not use a Proxy. I tried opening all ports in my routers firewall.

Still only a black window.

Now using Ubuntu 11.10 64bit..

share|improve this question
if you run googleearth from a terminal what errors (if any) are reported (copy and paste into your question). – fossfreedom Nov 22 '11 at 20:06
I have same problem. But only in Unity and Gnome (3 and Classic). I used Software Center and installed Xfce desktop, because Unity was too slow even if I disable all effects. It was just to slow for me. In login screen I choose between Gnome,Unity and Xfce. I was really surprised when I saw that in xfce mode, Google Earth works just fine.But in Unity, and Gnome it does not.Maybe this fact will help someone to figure it out, what's the problem. – Marko Jun 2 '12 at 9:28

Which (or any) of these methods have you tried?

Method A: (download binaries)

wget -q -O - | sudo apt-key add -
sudo sh -c 'echo "deb stable main" >> /etc/apt/sources.list.d/google.list'

sudo apt-get update && sudo apt-get upgrade

sudo apt-get install lsb-core
sudo apt-get install ia32-libs    (needed for Ubuntu 11.10, 64bit)

sudo apt-get install google-earth-stable

Method B: (download & compile)

sudo apt-get install build-essential lsb-core
sudo apt-get install googleearth-package

sudo make-googleearth-package --force
share|improve this answer
Thank you for that clear response. Now what version of Google Earth did you try to install? – all4naija Nov 25 '11 at 12:39
It is intermittent. It worked for a few days then back to the black screen, I get a server failure now. Tried port forwarding, connected hard wired to a LAN, but haven't been able to get it back. I checked permissions, all correct. It must be a google earth issue, or I am extremely unlucky, because no matter what hardware I used I could never get it working. I did get the best results with the suggestion here though. Thanks – pst007x Nov 29 '11 at 4:38
Due to intermittent failure, I tried installing BETA version: Google Earth: (beta), Build Date: 10/2/2011, Build Time: 4:00:42 am,Renderer: OpenGL, Operating System: Linux (, Video Driver: Tungsten Graphics, Inc, Max Texture Size: 8192x8192 available video memory information not available, Server: – pst007x Nov 29 '11 at 4:41
Found the problem. ISP DNS is rubbish! Changed my DNS and worked! OPENDNS nameservers are always: and, SITE – pst007x Nov 30 '11 at 20:33

You may need to install 3D drivers if you have an Nvidia or Radeon card.

share|improve this answer
My laptop uses Intel, and I have checked 3D is enabled. I also have a PC desktop using Nvidia card, using the latest drivers on Ubuntu 10.10 and I am still having the same issue. It is though Google Earth program will not see that my graphics 3D is enabled. I wonder if there is a config file I can change to force Google Earth to not check for 3D perhaps. thanks – pst007x Oct 23 '11 at 8:14
I don't mean to offend anybody nor sound like a geek. The fact is that I have had same experience before and later found out it was due to censorship! Just check with your ISP provider for information, if their firewall is responsible for that or some other network related activities. – all4naija Nov 25 '11 at 2:04

you can also check if all the required libraries are properly linked to the executable with ldd /opt/google/earth/free/googleearth-bin , in particular look for the links with the GL related libraries.

share|improve this answer
tried that and the only odd thing is: => not found – pst007x Nov 29 '11 at 4:46

Which country are you at? I have found out that it behaves that way with the error(We are unable to connect to the Google Earth servers) popping up each time it tries to connect due to some country censorship of 'Google Earth'.

share|improve this answer
I am in the UK, no censorship here... I hope :-( – pst007x Nov 25 '11 at 10:10
up vote 0 down vote accepted

Found the problem. ISP DNS is rubbish! Changed my DNS and worked! OPENDNS nameservers are always: and, SITE LINK:

share|improve this answer

In router: Internet IP Address

Get Dynamically from ISP: yes

Domain Name Server (DNS) Address

Get Automatically from ISP: yes
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.