Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing Ubuntu 11.10, I configured my Sound Settings to be 5.1 + analog input. It works ok, but after closing and reopening Banshee, the sound channels reverts back to 2 channels, this also happens on changing the song (ie. next, previous) and also after a reboot.

The configuration dialog is still selected "5.1 + analog input" but there no 5.1 sound at all, only the default stereo 2 channels only.

To fix it I have to open sound settings and in the output tab reselect "Internal Analog surround 5.1"

Is this fixable?

share|improve this question
up vote 3 down vote accepted

I was just having the exact same problem. 2.0 to 5.1 upmixing was not working after changing the track manually on any player/program. The suggested fix worked temporarily, until a different track is chosen manually. But, fortunately i found a better and permanent solution. Try this:

sudo gedit /etc/pulse/daemon.conf
enable-lfe-remixing = yes

Hope this works for you too.

share|improve this answer
Great!, worked like a charm!!! – razor7 Dec 7 '11 at 0:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.