Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been to system settings and to User Accounts. My account is the only one on the system and I have previously been able to UnLock the screen so that I could set my account to login without password prompt.

That didn't make any effect on the system. I still have to enter a password to log in, but now I can't unlock the User Accounts dialog to make any changes at all. What do I need to reset?

note how the unlock box in the upper right hand corner isn't available for selection...

enter image description here

share|improve this question
2  
addendum: I am slowly losing control over my computer. I can no longer shutdown or reboot via any menu (only by holding the power button). Now my "mute" light is on, even though I have audio; pressing the mute button has no effect. I also have lost the ability to mount my external hard drive and pen drive, the error is "Not able to mount Extension Drive. Not Authorized". I feel betrayed by my unixy computer. Hal? is that you? –  John Kotrla Oct 19 '11 at 3:09
    
I think the problem is something to do with PolicyKit. That is a piece of software which controls the fine grained policies –  Manish Sinha Oct 23 '11 at 23:37
add comment

4 Answers

I just discovered your questions after it affected me too. Please take a look at following bug report: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/851055 It seems somethin is broken in lightdm (new default display manager in Ubuntu 11.10). The problem had first occured during the beta release of Ubuntu Oneiric and seemed fixed, but users are still reporting problems. At the moment there isn't much you can do. Subscribe to the bug report and show that it affects you. Wait for a new fix or downgrade to an older lightdm version.

edit: Of course you can do something. Remove lightdm as display manager and install "good old" gdm display manager. Open a terminal and enter: sudo apt-get remove lightdm to remove lightdm, next enter sudo apt-get install gdm to install gdm. Reboot

Hope lightdm gets fixed soon!

share|improve this answer
1  
You forgo the sudo dpkg-reconfigure gdm or else he would be left in an even more broken system –  Manish Sinha Oct 24 '11 at 10:43
    
And does changing to gdm.... affects anything –  Starx Feb 13 '12 at 12:34
add comment

Try sudo usermod -U username to unlock your account.

share|improve this answer
add comment

I had the same problem.

Setting the password to 'none' in Gnome 3 System Settings GUI meant I didn't need password to login but then couldn't unlock changes to user accounts anymore.

I solved it by changing the root password in the command line:

sudo passwd

The old password still worked, then I entered a new password, and now it works and can unlock user changes in the GUI again.

share|improve this answer
add comment

What you need to do is learn command line access for modifying users. You NEED the root password, or to make a setuid program made in C.

http://www.ahinc.com/linux101/users.htm

This has a pretty good rundown of how to do things with users in bash.

Really you should make an effort to learn bash, it will save you insurmountable amounts of trouble on and down the line. If you really want the power of Unix systems it comes from the shell and scripting.

share|improve this answer
    
-1, this doesn't answer the question. –  jrg Oct 23 '11 at 22:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.