Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am an upgraded user from Ubuntu 11.04 to Ubuntu 11.10 On Ubuntu 11.10 when I click on the Trash icon in the Unity launcher, it does not open the Trash can. Why?

share|improve this question

3 Answers 3

IF you did an upgrade from 11.04 to 11.10 then do this

gedit ~/.local/share/applications/mimeapps.list

In the [Default Applications] section you will find a line that starts with

inode/directory=

Delete the line & save

Again to note: this is only if you did a 11.04 upgrade to 11.10

Edit: This will shortly be addressed by an upgrade to nautilus, the new package is currently in oneiric-proposed & hopefully will be moved to oneiric main repo in near future, my bug on.

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/876788

share|improve this answer
    
I AM A UPGRADED UBUNTU 11.10 USER FROM 11.04, I TRY YOUR IDEA BUT COULD NOT FIND inode/directory= –  RAMESH Oct 19 '11 at 15:15

As an alternative press SUPER+T to open it from the keyboard. Hold SUPER key pressed to see what shorcut appears on the Trash Icon in the launcher (by default t)

You can also see the Trash Can if you open your home folder in the launcher.

As to why it does not opened directly when clicking on it I would suggest (if not yet done so) to update the system with any new packages. There are a couple of small bugs yet in the launcher but in a couple of weeks most/all of them should be gone.

If both do not work do the following:

To reset the icons of the launcher (In the terminal) type: unity --reset-icons

To reset Unity to the default version (In the terminal) type: unity --reset

Also make sure the folder TRASH folder exists. To check do the following:

  1. Open Nautilus
  2. Press CTRL+L to change the location bar to a bar the user can edit.
  3. Type in the location bar: trash:///. This should send you to the trash folder.

The Trash folder typically could be found in your home folder like ~/.Trash but since 11.10 I started finding it in ~/.local/share/Trash. This is much better since everything is localized and conforms to the specifications mentioned in the freedesktop standar (which I like).

share|improve this answer
    
I also try this before ask my question. –  RAMESH Oct 19 '11 at 15:46
    
Then do the following resets I added above. Just to make sure. If one of them work let me know since the cover a variety of small problems. –  Luis Alvarado Oct 19 '11 at 16:10

[Upgraded from 11.04 to 11.10]

I also had the same problem, the Trashcan launch icon would not open the Trash folder and display current contents (although right-click, Empty Trash worked without any feedback.) I also had other problems: when inserting a USB drive, an error message appeared -- don't remember the exact wording, but I think it mentioned gnome-display-properties -- to complain that the contents of the device could not be accessed (however, the Home Folder icon displayed it normally.) There were some other trivial UI problems, don't remember them, as I said, trivial. But a host of these "trivial" annoyances that all had other built-in methods to workaround them were fixed when, according to instructions I read elsewhere, I DELETED the mimeapps.list in ~/local/share/applications. This file is supposed to be removed during the upgrade to 11.10, and apparently it is not on some systems.

A file by this same name already exists in the global location /usr/share/gdm/applications. I checked after restarting, and the mimeapps.list did not reappear in the ~/.local/usr/share/applications location. Possibly, this file is created if you customize user settings for the Launcher somehow.

You may perform your own experiment with this file by renaming the mimeapps.list in the local location and restarting. If the results are not as hoped, you can just rename it back. Otherwise, you can then delete it. No sudo would be required for ~/.local/...

It might be helpful if other users would confirm here that they do not have a mimeapps.list file in the ~/.local/share/applications folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.