Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Login to 11.10 I input my password and shortly afterward I am asked for a keyring password.

I realize that I was asked for this during installation (second time lucky!) and I did enter a password (what a mistaka to maka). This now entails my having to input the keyring password on every boot up!

Looking at previous answers it would seem that the applications - accesories - password and encryption keys - was the suggested route. However I assume that was in Gnome (At this stage I look back in fondness!!!) Certainly, I don't get the same route in Unity!

I saw a reference to seahorse in a terminal - but this results in several error reports and a sub windows which does not seem to open.

The objective in this exercise is to log in using the login password and not also the keyring password!

any help would be appreciated - thank you

share|improve this question
    
If you start seahorse from a terminal, what output do you get? –  aquaherd Oct 18 '11 at 17:41
    
he hasn't started seahorse, because he thought Unity had replaced/removed Gnome. –  Jo-Erlend Schinstad Oct 18 '11 at 17:49
    
Can you edit your question with the previous answers you've tried? –  Jorge Castro Oct 18 '11 at 21:27
    

4 Answers 4

First of all, Ubuntu 11.10 is a Gnome distribution. What button you push to launch an app like Firefox (which is what a shell does, mostly), does not affect the Gnome infrastructure. Seashorse, which is the application you're talking about, is a Gnome application and hence is installed in Ubuntu 11.10.

You were not asked for a password to your keyring when you installed Ubuntu. You were asked for a password for your user account, and that's the one used for the default keyring as well.

Certainly, you do the exact same thing whether you use Unity, Unity 2D, Gnome Shell, xfpanel, or any other shell for Gnome. :)

share|improve this answer
    
There is a subtle question hidden in this page: "How do I get Ubuntu to stop asking me for my keyring login password." This answer seems to miss the question and only to lecture the poster on the non-differences between Gnome, Gnome Shell and Unity. –  phord Apr 25 '13 at 13:37

I'm using Ubuntu 11.10 with the Gnome Shell. The following procedure worked for me, I believe it should work with Unity as well:

  • start the "Passwords and Keys" application
  • find the "Passwords: default" entry
  • open the context menu for that entry (usually with a right mouse click)
  • select the "Change Password" option
  • enter your current password as the "Old Password", leave the fields for the new password empty
  • click "Ok"
  • confirm to "Use Unsafe Storage"

That should do the trick.

share|improve this answer

Even though the route is not the same, it's fairly easy to find the keyring in the Dash. Start typing "password", and the Password and Keys icon will immediately appear.

share|improve this answer

In the 'Details' section of the keyring password prompt you're facing after login, there should be an option (2nd from above, IIRC) that lets you auto-unlock your keyring after login. Select that option next time you're prompted for your password, and you should hopefully be fine.

share|improve this answer

protected by Community Feb 13 '12 at 16:41

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.