Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu Oneiric 11.10.

My understanding is that Gnome Classic is with Compiz effects, and Gnome Classic (No Effects) has no Compiz.

However, when i run Gnome Classic, compiz does not seem to be running. If I open compiz-settings-manager, I have all my settings, but none of them are taking effect.

Is there something I need to be doing to enable Compiz in Gnome Classic?


As requested in the comments of the answers, here is the output of ~/.xsession-errors:

gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=Is
Inhibited
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=Is
Inhibited
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=Is
Inhibited
gnome-session[20450]: DEBUG(+): Starting app: /org/gnome/SessionManager/App37
gnome-session[20450]: DEBUG(+): GsmAutostartApp: starting jockey-gtk.desktop: command=sh -c 'test -e /var/cache/jockey/check |
| exec jockey-gtk --check' startup-id=102cff201a509beb8813189506573089800000204500036
gnome-session[20450]: DEBUG(+): GsmAutostartApp: started pid:20888
gnome-session[20450]: DEBUG(+): Starting app: /org/gnome/SessionManager/App29
gnome-session[20450]: DEBUG(+): GsmAutostartApp: starting update-notifier.desktop: command=update-notifier startup-id=102cff20
1a509beb88131895065698387500000204500028
gnome-session[20450]: DEBUG(+): GsmAutostartApp: started pid:20889
gnome-session[20450]: DEBUG(+): GsmAutostartApp: (pid:20888) done (status:0)
Gtk-Message: Failed to load module "rgba"
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerC
hanged
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerC
hanged
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerC
hanged
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerC
hanged
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerC
hanged
gnome-session[20450]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerC
hanged
`menu_proxy_module_load': update-notifier: undefined symbol: menu_proxy_module_load

(update-notifier:20889): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': update-notifier: undefined symbol: menu_proxy_module_load

(update-notifier:20889): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': update-notifier: undefined symbol: menu_proxy_module_load

(update-notifier:20889): Gtk-WARNING **: Failed to load type module: (null)

`menu_proxy_module_load': update-notifier: undefined symbol: menu_proxy_module_load

(update-notifier:20889): Gtk-WARNING **: Failed to load type module: (null)
share|improve this question
add comment

4 Answers

up vote 8 down vote accepted

To solve this problem edit this file:

sudo nano /usr/share/gnome-session/sessions/gnome-classic.session

and replace this line:

RequiredProviders=windowmanager;notifications;

with this one:

RequiredProviders=windowmanager;

Then just logout and log back in and it should work fine. This solved the problem in my case.

EDIT 1:

1) to access the gnome panel menu now you need to use "windows key + alt + right click" on panels instead of "alt + right click"

2) another issue might be "alt + tab" but you just need to reassign it in Applications -> System Tools -> System Settings -> Keyboard -> Shortcuts

EDIT 2:

3) after system updates related to GTK or gnome you might need to reinstall any "custom" drivers for your graphics card, for e.g. NVIDIA linux driver

share|improve this answer
    
Yes works but loose the ALT function see my comment below –  robin0800 Oct 19 '11 at 2:36
3  
instead of "alt + right click" on panel use "windows key + alt + right click" and it works fine then :) another issue might be "alt + tab" but you just need to reassign it in Applications -> System Tools -> System Settings -> Keyboard -> Shortcuts –  Pawel Barcik Oct 19 '11 at 3:28
    
Good find, windows key + alt does indeed work, perhaps edit your answer above to include this info –  robin0800 Oct 19 '11 at 10:33
add comment

Gnome Classic should run compiz if you have acceleration enabled (you can try to run /usr/lib/gnome-session/gnome-session-check-accelerated; echo $? and it should return 0), if it returns something else, it's probably that you don't have harware acceleration and so fallback to GNOME classic (No effects).

If no, is running /usr/bin/gnome-wm --replace replace your current environment with compiz ?

share|improve this answer
    
I get 0 when I run the first command, and when I run /usr/bin/gnome-wm --replace, then Compiz comes alive (yay!). However, the only thing now is that if I log out and log in again, I lose Compiz. How do I make it stick? –  Dave M G Oct 18 '11 at 14:48
    
That's weird… Can you check that /usr/share/gnome-session/sessions/gnome-classic.session contains: DefaultProvider-windowmanager=gnome-wm. If so, please edit: ``/usr/share/xsessions/gnome-classic.desktop`, add --debug to the exec line and report your ~/.xsession-errors after login. –  didrocks Oct 18 '11 at 14:57
    
I followed your instructions and appended the tail end of the error log to the original question. The whole file was way to long to include here. I hope that the portion I provided is sufficient. Oh, and the DefaultProvider-windowmanager=gnome-wm line was where you said it should be. –  Dave M G Oct 18 '11 at 15:16
    
Yes you can remove notifications and you can also change gnome-wm to compiz. The only problem then is you loose the ALT key action and can't access the panel settings –  robin0800 Oct 19 '11 at 2:34
add comment

Just for completeness,

another solution that works for me is to add "/usr/bin/compiz --replace" to the GNOME startup applications via:

gnome-session-properties

I lost the Alt-RightClick functionality too (Windows+Alt-Rightclick is necessary) but Alt+Tab is still working.

kind regards

share|improve this answer
add comment

Compiz effects frequently fail to load at startup in Ubuntu 10.04. To enable Compiz, I have to logout then login again. This usually does the trick.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.