Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I managed to uninstall xserver-xorg completely, and now all I see when booting Ubuntu is a blank screen. I've tried reinstalling it through shell prompt (recovery mode) but every time I get errors similar to

Failed to fetch Could not resolve ''

I get similar (not exactly the same though) errors when running apt-get update or try to repair broken packages in recovery mode. It's not just which can't be resolved, it's also,, among others.

The Ubuntu desktop is not accessible, I can only make changes through the terminal in recovery mode, or through a bootable USB.

I'm running 64bit Ubuntu 11.10 with hybrid graphics (Intel HD and AMD).

I tried adding


to my /etc/resolv.conf file but it made no difference. Updating the hosts file like this didn't help either.




ping: unknown host

It seems I'm not even connected to any network, I will start investigating this right now.

apt.log & sources.list

What should I do?

share|improve this question
did you try doing a sudo apt-get update before installing packages? or changing the download server mirrors? – Nitin Venkatesh Oct 18 '11 at 13:59
I've added apt-get update to my question, same error there. By changing download server mirrors, do you mean like this? – JLinden Oct 18 '11 at 14:17
You're having DNS issues. If host hangs or fails, but ping works, you've confirmed it. Try setting the DNS server to in Network Manager. – Lekensteyn Oct 18 '11 at 17:14
That might be the cause, only problem is I can't access Network Manager, or anything but the terminal. – JLinden Oct 18 '11 at 17:28

I had this problem. It was because my wireless wasn't functioning for some reason while xserver wasn't running. I had to do a wired connection, then it all worked fine.

share|improve this answer
up vote 1 down vote accepted

I got it working by downloading some of the packages I needed through a bootable USB, and then installing them in shell prompt (Recovery mode).

I don't know exactly what packages fixed my computer, but I think the ones I tried was:

  • xserver-xorg-video-all
  • xserver-xorg-video-intel
  • xserver-xorg-video-openchrome
  • xserver-xorg-input-evdev
  • xserver-xorg-video
  • xserver-xorg

After installing these, I could finally boot the computer into a semi-working state (some graphical bugs) and install updates to fully get xorg working again.

Lukens solution with a network cable seems more intelligent now though..

share|improve this answer

The problem is that the direction is bad writed, here is the really link:

share|improve this answer
What can I do to fix this? There are a couple of errors regarding ../pool/main/x/.. as well though – JLinden Oct 18 '11 at 14:55
Only click on the link and install manually – S8A Oct 18 '11 at 14:58
As I mentioned in my question, I can only access the terminal through recovery mode since Ubuntu just gives me a blank screen now. – JLinden Oct 18 '11 at 15:14
The URL I first wrote in my question was not the one I got in the error message, I've fixed it now. Sorry about that. – JLinden Oct 18 '11 at 20:16

The /etc/resolv.conf ineditable, to avoid DNS problem I had to add to /etc/hosts the ip of servers echo "" >> /etc/hosts echo "" >> /etc/hosts

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.