Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Am relatively new to Ubuntu. Currently running 10.10, which was an upgrade from 10.4, which was an upgrade from 9.10, which was a fresh install.

Have never compressed anything in Ubuntu, but because I wanted to use the contents of a large folder on a Windows machine, I installed 7zip. Using Places, I navigated to the folder I wanted to compress, right-clicked, chose Compress, selected 7-zip and started the compression. This took many minutes to complete (the final 7z file is over 2.2 GB), but when I copied it to the windows machine, 7-zip handles it fine.

However, now when I open Places, the Home Folder, User folder, Documents, Music, Pictures, Videos and Downloads all open the Archive Manager which gives an error message that it "Could not create the archive" because the "Archive type not supported."

If I open Places/Computer choose the usr folder from places on the left and right-click/Properties on any of the folders, Music for instance, there is no place to change the "open with."

Anyone know how to get this working again.

share|improve this question
    
I don't understand your question. Do you have problem compressing file? Or do you have problem with 7zip format? Or the problem is to open some file types with a predefined application? –  neuromancer Nov 8 '10 at 21:31
    
I have the same problem and am surprised that this question is still not answered. I think it is explained by op very clearly. The problem is with the "Places menu". Home folder and other folders actually open Archive manager with an error message, instead of the designated folder. Only item that works is Computer, and from that window it is possible to open Home folder etc. normally. Anyone knows how to fix Places menu shortcuts so it opens folder windows as it should instead of archive manager? pic here: www4.pic-upload.de/24.01.11/1qypag42gj41.jpg @maco: your answer might –  user9486 Jan 25 '11 at 2:02

2 Answers 2

up vote 4 down vote accepted

Right-click -> Open with Other Application (just like you did before), and select File Browser. Make sure the checkbox at the bottom that says

Remember this application for "folder" files

is checked.

share|improve this answer

Here's the answer I found after 3 hours of frustration!! Works great!!

 gedit ~/.local/share/applications/mimeapps.list

Change the line starting:

inode/directory=

to read:

inode/directory=nautilus-folder-handler.desktop;*
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.