Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday i installed Ubuntu 11.10 on my desktop computer, and the wireless connection is so slow that it takes 3 minutes to load google.com. With my Ubuntu netbook also running 11.10 i do not have that problem.

Please help me

share|improve this question
    
Maybe related: askubuntu.com/questions/79721/… –  mogsie Feb 29 '12 at 0:15

2 Answers 2

Unfortunately, there really is not enough information to know what is happening here. Would be nice to know what the latency to and from the wireless router is, and then what the latency between your browser and perhaps yahoo.com or google.com, then try to determine what the hardware is within the desktop that is providing the wireless connection.

Hard to say it is a wireless driver without knowing much more information about the issue. Here is what I would do in order to diagnose in order of likely ease and best return of resolution to you:

1) Check your browser's settings in the desktop computer for any proxy connections (not likely if newly setup though)

2) Check to see if your computer's connection to your Wireless Access Point is solid and low-latency:

user@host~:$ping xxx.xxx.xxx.xxx

where $xxx.xxx.xxx.xxx represents the IP Address of the wireless access point or router. You will probably only need to gather about 5 to 10 packets and then interrupt the ping command with a simple CTRL+C:

user@user~:$ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_req=1 ttl=64 time=1.81 ms
64 bytes from 192.168.1.1: icmp_req=2 ttl=64 time=0.398 ms
64 bytes from 192.168.1.1: icmp_req=3 ttl=64 time=0.425 ms
64 bytes from 192.168.1.1: icmp_req=4 ttl=64 time=0.404 ms
64 bytes from 192.168.1.1: icmp_req=5 ttl=64 time=0.447 ms
^C
--- 192.168.1.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4000ms
rtt min/avg/max/mdev = 0.398/0.698/1.816/0.559 ms

In this example the IP Address is a standard home Wireless Router default administrative IP address and the ping results are as shown. The round trip time is no an issue there.

3) Next, ping google.com or yahoo.com or some other site for the same results. Do not rely solely on one site as you may have a problem with a local content server from a content mirroring service. Even the largest providers in the world have occasional issues with their content services, it happens.

user@host~:$ping google.com
PING google.com (74.125.227.50) 56(84) bytes of data.
64 bytes from dfw06s06-in-f18.1e100.net (74.125.227.50): icmp_req=1 ttl=59 time=32.1 ms
64 bytes from dfw06s06-in-f18.1e100.net (74.125.227.50): icmp_req=2 ttl=59 time=30.7 ms
64 bytes from dfw06s06-in-f18.1e100.net (74.125.227.50): icmp_req=3 ttl=59 time=31.9 ms
64 bytes from dfw06s06-in-f18.1e100.net (74.125.227.50): icmp_req=4 ttl=59 time=33.2 ms
64 bytes from dfw06s06-in-f18.1e100.net (74.125.227.50): icmp_req=5 ttl=59 time=32.1 ms
^C
--- google.com ping statistics ---
6 packets transmitted, 5 received, 16% packet loss, time 5008ms
rtt min/avg/max/mdev = 30.777/32.060/33.217/0.777 ms

The results here are a bit misleading, simply because the last packet was lost because of the interruption of the ping command, but the connection is stable and normal.

4) If you are seeing something different at this point, then you should probably verify that your desktop has the proper drivers for your wireless card. Try this command to gather information about your card:

user@host~:$sudo lspci

This should provide a full list of your devices, including the wireless device.

5) Next, go to System Settings, Additional Hardware and then allow the system to search for additional drivers. If any additional drivers are required for the Wireless card, install them.

6) Restart the system as required to allow the newly installed driver (if any) to take effect.

HTH. Have a nice day.

share|improve this answer

This is probably caused by incorrect wifi drivers. You should install drivers for your wireless card. You could try going to System settings -> Additional Drivers, and see if there are any proprietary drivers to install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.