Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using nautilus on xfce and oneiric, but the desktop of nautilus shows up although I have activated it via gconf, e.g. by

gconftool-2 \                                                                   
--type bool \             
--set /apps/nautilus/preferences/show_desktop false

I remember this had worked on previous versions of Ubuntu.

share|improve this question

5 Answers 5

up vote 8 down vote accepted

Install gnome-tweak-tool. There is a setting called "Have file manager handle the desktop" that you can switch off.

The configuration system has been replaced, so gconf won't work in all cases anymore. However, not all apps have been converted yet, so it's still present.

share|improve this answer
Does it work for all desktop variants? I was about to post this as an answer but I wasn't too sure. –  jokerdino Oct 18 '11 at 9:20
Just tried it on XFCE and it works, thanks! –  Johann Philipp Strathausen Oct 18 '11 at 9:24
Yes this should work on all variants. –  Another Googler Oct 24 '12 at 1:02

For gsettings based desktop environments (such as those that use the openbox window manager, as Shailesh has pointed out), the following gsettings corresponds to your gconftool-2 invocation:

gsettings set org.gnome.desktop.background show-desktop-icons false
share|improve this answer

The following command works with OpenBox:

gsettings set org.gnome.desktop.background show-desktop-icons false

The gconftool based command do not work with OpenBox.

share|improve this answer

I'm running openbox over 12.10 and disabling the "Have file manager handle the desktop" option in Gnome tweak tool was not enough. I also had to open dconf and go to org/Gnome/desktop/background and make sure draw-background and show-desktop-icons are not ticked off. My dconf solution without the tweak tool option did not work for me either. Both solutions are needed (in my case).

Gconf desktop/background did not work for me, nor any other configuration via gconf (I believe gconf does work on older systems).

share|improve this answer

none of the above solutions workedf for me with xfce in debian

however: Settings -> Desktop -> Icons - > Icon type: None

this worked for me!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.