Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed a fresh install of Ubuntu 11.10 64-bit on my notebook.

I personally prefer Rhythmbox over Banshee so I searched for and installed it from the Ubuntu Software Center. (including all plugins that were listed). Unlike previous versions of Ubuntu (11.04, 10.10, etc..) the (previous, play/pause, next) controls have been removed from the sound menu. Rhythmbox is still listed (above "Sound Settings...") but when clicked all it does is open the application. To add insult to injury the Banshee controls are displayed right above it - even though that application isn't running.

  • I have tried opening Rhythmbox from the Unity dashboard, the Unity launcher, and the sound menu with the same results.

  • I've also verified that I had rhythmbox-plugins installed.

  • I even tried to remove and install the application. Still no controls.

It looks like they were removed and that we are now expected to use Banshee. Why?

Here is a screenshot of what my sound menu looks like when I'm playing a file in Rhythmbox. (Notice that Banshee isn't running but it's controls are displayed) In Ubuntu 10.10 and 11.04 Rhythmbox had controls just like Banshee's controls in the screenshot.

Screenshot of sound menu with Rhythmbox playing a file. Banshee isn't running.

share|improve this question
1  
To take a screenshot of a menu, you can open the Screenshot application from the dash and tell it to "Grab after a delay." –  Dylan McCall Oct 18 '11 at 6:49
    
Thank you Dylan - I was able to attach a screenshot of the menu thanks to your excellent tip. –  user27451 Oct 19 '11 at 9:29
add comment

2 Answers

up vote 8 down vote accepted

As jnv stated there should be rhythmbox-plugins package installed and MPRIS D-Bus interface plugin enabled in rhythmbox.

share|improve this answer
    
The package was never a problem. Rhythmbox was originally installed through the Ubuntu Software Center and rhythmbox-plugins was automatically installed at the same time. I checked the 'MPRIS D-Bus interface' plugin you mentioned and sure enough it was not enabled by default. Other users are reporting the same problem so this very well be a bug. Thanks for the answer Draco. :) –  user27451 Nov 5 '11 at 9:22
2  
I guess the plugin description ("Provides an implementation of the MPRIS D-Bus interface specification") may be of some value on a technical level but in my opinion is absolutely worthless to the novice user. "Enable this plugin to add player controls to your sound menu." would be a much clearer description usability-wise. I can't imagine the Ubuntu Rhythmbox team expects the novice user to know what the 'MPRIS D-Bus interface specification' is? –  user27451 Nov 5 '11 at 9:39
add comment

Easy fix here! Open up your terminal and type dconf-editor which will look like the screen image provided above in the previous thread by jokerdino. Click on apps then indicators then sound. The First option on the right is blacklisted-media-players. Inside those brackets type 'rhythmbox' to remove. You can type 'rhythmbox','banshee' if you want to remove both. This will completely remove all instances of either one showing up in sound menu on your status bar but does not effect functionality whatsoever.

share|improve this answer
1  
The OP wants to add Rhythmbox to the sound menu and not remove them. Read the question properly again! –  jokerdino Feb 15 '12 at 7:13
    
Excuse me I apologize for the misunderstanding. This will be how you remove them yes. In order for you to gain control in sound menu you must have the MPRIS D-Bus interface plugin enabled in rhythmbox. Putting 'rhythmbox' in interested-media-players will only provide the option to click to open the app in the sound menu. You will not have player controls. This is all done through MPRIS D-Bus. Once again sorry for misreading the post –  Scott Stookey Feb 15 '12 at 7:25
    
@ScottStookey - there is such thing as an edit button... –  Wilf Feb 22 at 18:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.