Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The problem was not resolved, but I went back to 11.04

1. Description of the Problem

The speaker works. When I plugin the headphone (tried 2 types), both the speaker and the headphone mute.

==============================================================

2. I found this. How can I try this on Lubuntu?

"All I needed to do was change the Profile on the Hardware tab of the Sound Setting screen from 'Analog Stereo Duplex' to 'Analog Stereo Output'." Link

=============================================================

3. Already tried

(I) [HP Pavilion dv6, IDT 92HD75B3] Line out does not mute internal speakers

Didn't work.

(II) HdaIntelSoundHowto

$ cat /proc/asound/card0/codec* | grep Codec
Codec: Conexant CX20549 (Venice)

$ sudo gnome-open /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz
gives me a file, but for conexant, there're only Conexant 5045, Conexant 5047, Conexant 5051, Conexant 5066.

(III) [Bug 876020] Re: [8932CTO, Conexant CX20549 (Venice), Green Headphone Out, Left] No sound at all(Note: I needed rebooting.)

(i) Now when I plug in the headphone, the sound comes out of both the speaker and the headphone.

(ii) automute option in alsamixer is gone.

(iii) I cannot change the volume with Fn+F10/F11 any more.

=============================================================

4. More Info

$ sudo lshw -c sound

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)

$ sudo lshw -c sound

*-multimedia            
   description: Audio device
   product: 82801H (ICH8 Family) HD Audio Controller
   vendor: Intel Corporation
   physical id: 1b
   bus info: pci@0000:00:1b.0
   version: 04
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=HDA Intel latency=0
   resources: irq:45 memory:f0300000-f0303fff

$ sudo leafpad /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

; Path for mixers that have a 'Speaker' control
;
; See analog-output.conf.common for an explanation on the directives
[General]
priority = 100
name = analog-output-speaker

[Element Hardware Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master Front]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = front-left,front-right

[Element Master Mono]
switch = off
volume = off

; This profile path is intended to control the speaker, not the
; headphones. But it should not hurt if we leave the headphone jack
; enabled nonetheless.
[Element Headphone]
switch = mute
volume = zero

[Element Headphone2]
switch = mute
volume = zero

[Element Speaker]
required = any
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Desktop Speaker]
switch = off
volume = off

[Element Front]
switch = mute
volume = merge
override-map.1 = all-front
override-map.2 = front-left,front-right

[Element Rear]
switch = mute
volume = merge
override-map.1 = all-rear
override-map.2 = rear-left,rear-right

[Element Surround]
switch = mute
volume = merge
override-map.1 = all-rear
override-map.2 = rear-left,rear-right

[Element Side]
switch = mute
volume = merge
override-map.1 = all-side
override-map.2 = side-left,side-right

[Element Center]
switch = mute
volume = merge
override-map.1 = all-center
override-map.2 = all-center,all-center

[Element LFE]
switch = mute
volume = merge
override-map.1 = lfe
override-map.2 = lfe,lfe

.include analog-output.conf.common
share|improve this question
    
Very well made question. I think you cover everything I could ask for. Is the computer you are using a Laptop HP DV6 just to be sure that the 3rd part is the same as your computer. –  Luis Alvarado Oct 25 '11 at 2:50
    
I went back to 11.04. –  Robin002 Oct 29 '11 at 6:54
    
If you went back to 11.04 - then this question should be closed since we can no longer get feed back from you on trying stuff. –  fossfreedom Oct 29 '11 at 7:32
    
Closing this question as it seems you're no longer on 11.10 - if this isn't the case please flag the question for review stating the issue is still present. –  Marco Ceppi Oct 29 '11 at 16:03
    
@MarcoCeppi I experience the same issue on LUbuntu 12.04. –  Calmarius Oct 5 '13 at 13:42
add comment

closed as too localized by Marco Ceppi Oct 29 '11 at 16:03

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I don't know if this would work but it has for me before on different hardware. You could try to edit the /etc/modprobe.d/alsa-base.conf file adding at the end of the file the following

options snd-hda-intel position-fix=1

then, restart your machine and check if it works now.

share|improve this answer
    
Thanks for the suggestion, but didn't work. –  Robin002 Oct 18 '11 at 7:06
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.