Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I notice quite a few other questions on this subject, but so far none of them help me.

I have a Asus X59GL laptop that I upgraded from Natty to Oneiric and I'm experiencing a new bug. My touchpad gets disabled while I use the computer, i.e. it doesn't go to sleep or anything - I just find the touchpad doesn't work anymore after an undetermined amount of time. I unticked the "Disable while typing" option, but that didn't fix it. I can't find a "touchpad:touchpad" option in gconf, but somehow I don't think that would help me, since the touchpad is very enabled until it gets disabled.

I managed to get Google to tell me about synclient, and just earlier I re-enabled the touchpad using

synclient touchpadoff=0

from the terminal.

But I'd like not to do that.

There's no Fn-key combo for disabling the touchpad and this only started happening after upgrading to Oneiric.

Any ideas what disables the touchpad so I can go poke it with a stick?

share|improve this question
add comment

3 Answers

I'm not sure thereis a clear reason why yet, there could be some hardware specific difference involved here. Myself & several others have seen this disappear by disabling the option, though I guess for others it is non effectual. (I have Dell

You may want to keep an eye on the current main bug report https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/868400

running this command seems to be the most effective method to prevent

gsettings set org.gnome.settings-daemon.plugins.mouse active false
share|improve this answer
add comment

Have you tried turning off the "Disable touchpad while typing" feature? It's located in mouse and touchpad settings.

I haven't tested it for a long time yet, but I heard this is a pretty unreliable feature so maybe it's the cause of your (our) problems? I have the exact same problem as you, and in my case disabling and enabling of the touchpad through Fn key or the specific button works, but using the fn-key doesn't enable the touchpad again after it expectantly stops responding, but the commands you gave do enable it again...

Not sure though if that is the actual cause of the problem...

share|improve this answer
add comment
up vote 0 down vote accepted

I've actually found the answer after a long time. There IS a Fn combo, but it's just not painted on the keyboard. Fn+C toggles the keypad. And I was pressing Fn+C in the dark instead of Ctrl+C, because someone who designs laptop keyboards for a living thought it would be alright to put the Fn key where the Ctrl key normally is.

So in the end it's not a Ubuntu bug. It's a laptop "feature".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.