Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 11.10 from 11.04, everything went fine, still hate unity and all that. But my battery status is not showing up at all, even on my laptop. There isn't even any spaces for it, there is only the Mail Icon, Wirelesss Icon, Sound, Time, [username] and Power. I have tried several different things to get it, but I am at a loss. Please help

  • I've already tried to install indicator-power and it is installed.
share|improve this question
    
this might sound stupid, but does ubuntu come in different versions, such as one for Desktops and one for Laptops? –  Omid Oct 18 '11 at 2:26
    
I think the battery icon won't be visible in the panel if it is fully charged. Check back later when the battery is not full. –  jokerdino Oct 18 '11 at 2:28
1  
i used it today, after a full night of charging. It gave me about 4 hours of use and then all of a sudden shut down, probably due to the lack of battery. I did not see the battery indicator at any point the whole day. –  Omid Oct 18 '11 at 2:31
    
I am going to try to reinstall. –  Omid Oct 18 '11 at 2:35
    
What workaround / fixes did you end up trying? Did anything so any promise / partial improvement? –  david6 Nov 20 '11 at 19:42
add comment

10 Answers

the indicator is:

indicator-power

Make sure that is installed.

sudo apt-get install indicator-power

If it is installed I would try re-installing it.

sudo apt-get purge indicator-power

sudo apt-get install indicator-power

I have not found an indicator file to edit that controls them loading or not.

share|improve this answer
add comment

I was having the same problem on 12.04 ... No power indicator applet (upon login -- saw one AT the login screen).

Running gsettings list-recursively|grep settings-daemon spat out that:

org.gnome.settings-daemon.plugins.power active false

In terminal,

gsettings set org.gnome.settings-daemon.plugins.power active true

... logged out and back in and I was good.

This was a fresh install from ISO of 12.04, so for those of you seeing two icons, you might want to set "....plugins.power active false" and see if one goes away.

share|improve this answer
    
I'm not seeing that here on two fresh installs (32- and 64-bit). The indicator not showing seems to be the consequence of the disabled power plugin in g-s-d. Are you sure you didn't disable it yourself (maybe added anything to the kernel boot line in GRUB)? Anyways, I suggest to file a bug report (I'd pick the gnome-settings-daemon package - don't worry, if that's wrong, bug control people will fix it for you). –  htorque Apr 28 '12 at 11:32
    
Mine came back automatically after running the commands. No need for logging out and back in again. –  Parto Jan 14 at 14:30
add comment

The indicator is called: indicator-power. You can try this 3 solutions preferably by their current order:

1)

Confirm that it is installed:

sudo apt-get install indicator-power

If installed, try removing it and reinstall:

sudo apt-get purge indicator-power

sudo apt-get install indicator-power

2)

If no avail, run the configuration utility:

gnome-settings-daemon

3)

If you got here, it's time to try an alternative monitor package:

How to add a detailed battery indicator to Ubuntu


This solutions were found at 11.10 No battery status icon - Ask Ubuntu

share|improve this answer
add comment

You have just updated to Ubuntu 11.10 (Oneiric) from 11.04 ..

Note: I did that too, on my netbook. I eventually gave up, and installed a new Ubuntu 11.10 instead.

I have a battery indicator, working correctly, showing percentage, etc.

There is an outstanding (unresolved) bug for this issue in LaunchPad.

https://bugs.launchpad.net/ubuntu/+source/ubuntu-mono/+bug/801180/comments/30

SUGGESTIONS: (in no particular order)

  1. Change theme to (or away from) 'Radiance'. Make sure this is not an icon issue.

  2. Purge and re-install indicator-power (as suggested by cprofitt).

  3. Remove any revenants from (older) Unity, etc.

    (get settings, for curiosity's sake)
    gsettings get com.canonical.Unity.Panel systray-whitelist
    
    (should look something like:)
    ['JavaEmbeddedFrame', 'Wine', 'scp=-dbus-service', 'Update-notifier']
    
    (clear whitelist)
    gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
    
  4. Try an alternative monitor package ..

    How to add a detailed battery indicator to Ubuntu

    http://www.omgubuntu.co.uk/2011/02/battery-applet-status-ubuntu/

share|improve this answer
add comment

I had the same problem both with 11.10 and with 12.04, and the other answers here didn't fix it.

Running gnome-settings-daemon gave me a functional battery indicator again.

share|improve this answer
add comment

Use dconf-editor. If you don't have it installed, you can do so, by just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get install dconf-editor

dconf-editor window

share|improve this answer
add comment

Alt + Right Click over the bar, so you will can configure/add/move applets. With the complete indicators miniaplication, come the battery indicator. That work for me with ubuntu 12.04.

share|improve this answer
    
As far as I can tell, <Alt> right click does absolutely nothing for the Unity top panel. That was Gnome 2.x convention. –  fabricator4 Dec 4 '12 at 18:46
add comment

Fighting with this issue, I have found that the proprietary driver modules for the NVIDIA graphic card, were indeed messing up with the battery icon, with the volup and voldown function, and with the shutoff button in the keyboard.

I simply deactivated these controllers and it came back to normal. Go figure. Cheers.

share|improve this answer
add comment

Battery indicator should run with the Unity Panel, but sometimes is inhibited for strange reasons.

You can try to force the daemon to run, writing gnome-settings-daemon in the terminal.

If it works, and you see the battery indicator in the panel, you can add the command to the Startup Applications.

How do I start applications automatically on login?

It work great for me, I hope it can help you!

share|improve this answer
    
Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. –  RolandiXor Oct 26 '13 at 17:51
    
Ok thanks! I did this to achieve as much as posible people. I'm not encourage to mark questions as duplicate, but if you recommend it... then I will do next time. Thankyou! –  Sergio Oct 31 '13 at 14:52
add comment

I had this issue for a long time.

acer aspire 5553 on ubuntu 13.04. I had no battery under /proc/acpi/battery or /sys/class/power_supply

Just updating the linux kernel to latest 3.11.1 solved it. Maybe this might help many.

http://ubuntuhandbook.org/index.php/2013/09/kernel-3-11-1-released-install-upgrade-in-ubuntu-linux-mint/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.