Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to open a file that has been downloaded from Chrome, or any folder in the menu bar "Places", evince opens with an error.

The error does not occur when I open a file with a particular program from the command line (ie: gnumeric myfile.xls) or if I open and navigate from Places>Computer, although it does occur with Places>Home Folder, Places>Desktop, etc.

For example, this is the result of clicking on Places>Desktop:

enter image description here

I have tried the following:

  • Checking the settings for a given filetype to see if preferred application is 'evince', but it is not. I have followed this guide.
  • Checking the settings on Chrome, but I can not find anything related to it.
  • removing evince: received 'Failed to execute default File Manager'...
share|improve this question
    
Might be an ugly hack, but try uninstalling evince. –  Capt.Nemo Oct 22 '11 at 17:04
    
@Capt.Nemo it might have been an ugly hack that didn't work, but it pointed me to the answer posted below. Thanks. I'll give the bounty to you if you write it up. –  David Oct 24 '11 at 15:45

2 Answers 2

up vote 3 down vote accepted

Need to change your default file manager. Either follow the steps at help.ubuntu.com, or simply type

 exo-preferred-applications

at the command line, select the 'utilities tab' and switch to your favorite file manager (e.g. Nautilus, Thunar).

share|improve this answer

Try uninstalling evince

sudo apt-get remove evince

With evince no longer on the machine, check what response chrome gives to opening files, and it might point you in the right direction.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.