Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 11.10 (what a mistake) and was using CompizConfig. Just clicking around in CompizConfig, my launcher disappeared. Rebooting doesn't help. unity --reset ends with 'Initializing session options...done' and if I try to kill it, the machine hangs. Any advice?

Update: Using Ubuntu 2D works around the problem.

share|improve this question
    
Kubuntu doesn't use Unity, and subsequently, doesn't have the Unity launcher. –  mikewhatever Oct 17 '11 at 22:52
add comment

2 Answers

up vote 1 down vote accepted

The orig. issue was likely caused by the unity plugin becoming unset, going back into ccsm & re-enabling the unity plugin may of fixed

share|improve this answer
add comment

Did you have another user account just to test if it works well on it ?...

I don't "see" the problem, but I think this can be solved simply by removing the old configuration files from your user folder.

Be careful because it will remove all your configurations, and they will be reset to default.

To do this (at your own risk), you must just remove the .gconf folder under your Home folder, since the problem seems to be a configuration related problem.

Be careful when removing configuration folders, even the worst that can happen is that your configuration are reset, important stuff could be removed by error.

Hope this will help.

share|improve this answer
    
It turns out I like Ubuntu 2D better since I can double click the title bar of a window and collapse it to a bar. This didn't work in Ubuntu. –  Noel Yap Oct 18 '11 at 0:14
    
There are some things I don't like about Ubuntu 2D so I tried moving .gconf out of the way. That didn't work. I also tried moving .compiz and .compiz-1 out of the way. That didn't work, either. –  Noel Yap Oct 18 '11 at 1:42
    
Unity-2D is not influenced by compiz since it is not using it, for instance if you try to run unity-2d-panel (for example), in KDE, Gnome3 or any other DE it will work and you will see it running normally, but if you try the Unity-3D which is nothing else but a "plugin" to compiz this will not work. But what things did you dislike in Unity-2D ? (The only reason I use Unity-3D or Gnome-Shell instead of Unity-2D it's because there is no "Window Snapping" :S) –  aliasbody Oct 18 '11 at 10:38
    
It's kinda strange. When I double click on a window bar, normally the window will collapse into only a window bar. In Ubuntu, this didn't work and Chrome would collapse into a 'shadow' (no better way to describe this) that I could no longer open. In Ubuntu 2D, collapsing into a bar works except for Chrome in which it maximizes the window. –  Noel Yap Oct 18 '11 at 15:44
    
Oh, and I can't change the number of rows and columns in the workspace switcher using Ubuntu 2D. –  Noel Yap Oct 18 '11 at 16:12
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.